Pages: [1] 2 3   Go Down
Author Topic: stk500_recv(): programmer is not responding  (Read 21603 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 6
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Everytime I try to upload i get this message, can anyone tell me what this means?
Logged

California
Offline Offline
God Member
*****
Karma: 14
Posts: 629
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

It means that you are communicating like you do not have a programmer connected.

More info would be helpful, i.e. platform, PC, and what you are trying to do.
Logged


Offline Offline
Newbie
*
Karma: 0
Posts: 6
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Im running on a Mac OS X 10.6.8.... I basically just hooked it up and tried running one of the examples onto it and that's the message I received...
Logged

California
Offline Offline
God Member
*****
Karma: 14
Posts: 629
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Did you set the "Board" and the "Serial" in the "Tools" menu?
Logged


Offline Offline
Newbie
*
Karma: 0
Posts: 6
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

ya, I did that...for some reason it works on my computer at school, but not on my mac laptop...thanks for replying by the way.
Logged

California
Offline Offline
God Member
*****
Karma: 14
Posts: 629
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

No problem.

Which Serial Port dev are you using, dev/tty.usbmodem or dev/cu.usbmodem?
Logged


Offline Offline
Newbie
*
Karma: 0
Posts: 6
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Alright! so there is the problem... the only ports that show are bluetooth ones for some reason... bluetooth-PDA-sync and bluetooth-Modem, there is two of each (tty. and cu.)

Any reason why the USB ports are not showing up?

I apologize for my lack of knowledge on the subject...



Logged

California
Offline Offline
God Member
*****
Karma: 14
Posts: 629
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Your driver did not install.  It should have been automatic.  Does the user account you are using on the Mac have sufficient permissions for installing devices?
Logged


Offline Offline
Newbie
*
Karma: 0
Posts: 6
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

it should, I've never encountered any problems like that before... should I try re-installing?
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 1
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I had the same problem!

If you are using an Arduino Nano w/ OSX you need to install the drivers.

Download and execute it:
http://www.ftdichip.com/Drivers/VCP/MacOSX/FTDIUSBSerialDriver_v2_2_14.dmg

And you'll find this files:
  • FTDIUSBSerialDriver_10_3.pkg which is specific to OSX 10.3 (Panther)
  • FTDIUSBSerialDriver_10_4_10_5_10_6.pkg which is specific to OSX 10.4 (Tiger), OSX 10.5 (Leopard)
    and 10.6 (Snow Leopard).

Execute "FTDIUSBSerialDriver_10_4_10_5_10_6.pkg" if you are using OSX 10.5+ (Leopard+)

Best!
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 6
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

bro, you're a star!
thanks for that man, it works perfectly now.
 time to delve into the world of arduino!


Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 10
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Wow, all this feedback is great. However, I still can't get my Uno R3 communicating with my Macbook running OS 10.6.8 and Arduino 1.1 . Although not needed I've loaded the FTDI driver and still "no dice"

Arduino sees the board. The Serial connection is listed as tty.usbserial.  Should that be tty.usbmodem ??
The board is getting power is simply fails the upload.

Any suggestions? I thought this was supposed to be easier on a Mac.
Logged

California
Offline Offline
God Member
*****
Karma: 14
Posts: 629
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
Arduino sees the board. The Serial connection is listed as tty.usbserial.  Should that be tty.usbmodem ??
The board is getting power is simply fails the upload.

I think it can work either way, but if you post a thread in Installation & Troubleshooting, there are a lot of Mac users that can help.  The only case I ran into on a Mac was Execution permissions.
Logged


Offline Offline
Newbie
*
Karma: 0
Posts: 5
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I have the exact same error, but I have even fewer complications so I have no idea how I could have messed anything up  smiley-eek.

Arduino Uno
Running version 1.0.1

Mac OS X Version 10.7.4
Serial Port: /dev/tty.usbmodem1d11


Uno means no drivers are necessary, according to the setup instructions.

I just plugged the board in for the first time.  I got a green LED, so I ran the Arduino application, loaded Blink, and got the error in this thread's title.  The RX Led blinked 3 times but that's all I got.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 5
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I've checked the troubleshooting guide, and I've searched the forums but I have not found a solution to this.  Any hints?
Logged

Pages: [1] 2 3   Go Up
Jump to: