Pages: 1 [2] 3   Go Down
Author Topic: stk500_recv(): programmer is not responding  (Read 21572 times)
0 Members and 1 Guest are viewing this topic.
California
Offline Offline
God Member
*****
Karma: 14
Posts: 629
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

So the "A new network interface has been detect" box did not come up after plugging in the Uno?

You will have to bear with me until a real Mac user comes by smiley-wink
Logged


Toledo, Ohio
Offline Offline
Newbie
*
Karma: 0
Posts: 1
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

I keep getting the same problem as well. My mac recognizes the board and everything yet when I try to upload a simple test program it fails and says programmer is not responding. Im running mountain lion 10.8.2. The correct board and serial port is selected.  Any feedback would greatly be appreciated. Thank you!
Logged

California
Offline Offline
God Member
*****
Karma: 14
Posts: 629
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Does "Network Preferences" show the Uno anywhere?  If the driver enumerates the Atmega8/16u2 it should show up as a device on the network.  If so, what kind of properties does it have?
Logged


Offline Offline
Newbie
*
Karma: 0
Posts: 10
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I solved this problem by selecting a different board. I have an Uno R3 Plus. However, it is an OEM board which means different chips. I was able to get it to work by selecting the Duemilanove ATmega328. works fine now.
Logged

California
Offline Offline
God Member
*****
Karma: 14
Posts: 629
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

I solved this problem by selecting a different board. I have an Uno R3 Plus. However, it is an OEM board which means different chips. I was able to get it to work by selecting the Duemilanove ATmega328. works fine now.

I was wondering why they call it an Uno not a Duemilanove Plus smiley-wink
Logged


Offline Offline
Newbie
*
Karma: 0
Posts: 5
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

So the "A new network interface has been detect" box did not come up after plugging in the Uno?

You will have to bear with me until a real Mac user comes by smiley-wink

No, no dialog box appears when I plug in the Uno.

Does "Network Preferences" show the Uno anywhere?  If the driver enumerates the Atmega8/16u2 it should show up as a device on the network.  If so, what kind of properties does it have?

Network Preferences shows a USB Modem, Not Configured.  I do not believe that this is the Uno, however, because the entry persists even without the Uno plugged in.

I am fairly sure the Arduino application detects the Uno board, because when I plug the Uno board in, there are two more selections to choose from under Tools > Serial Port.

Thanks for the replies!
« Last Edit: October 26, 2012, 03:02:04 pm by James K » Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 10
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Another point, because my "Uno" was actually connecting as a Duemilanove-ATmega328 (not an Uno) the Mac created a serial connection. I loaded the FTDI driver to support this connection.
Logged

California
Offline Offline
God Member
*****
Karma: 14
Posts: 629
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

So the "A new network interface has been detect" box did not come up after plugging in the Uno?

You will have to bear with me until a real Mac user comes by smiley-wink

No, no dialog box appears when I plug in the Uno.

Does "Network Preferences" show the Uno anywhere?  If the driver enumerates the Atmega8/16u2 it should show up as a device on the network.  If so, what kind of properties does it have?

Network Preferences shows a USB Modem, Not Configured.  I do not believe that this is the Uno, however, because the entry persists even without the Uno plugged in.

I am fairly sure the Arduino application detects the Uno board, because when I plug the Uno board in, there are two more selections to choose from under Tools > Serial Port.

Thanks for the replies!

Are you sure you have an Atemga8/16u2 and not an FTDI chip?  If you have an FTDI chip you will need to download:
http://www.ftdichip.com/Drivers/VCP/MacOSX/FTDIUSBSerialDriver_v2_2_14.dmg
Logged


Offline Offline
Newbie
*
Karma: 0
Posts: 5
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

snip

Are you sure you have an Atemga8/16u2 and not an FTDI chip?  If you have an FTDI chip you will need to download:
http://www.ftdichip.com/Drivers/VCP/MacOSX/FTDIUSBSerialDriver_v2_2_14.dmg

I have no idea what Atmega and FTDI are, but the box that the Uno board came in says Microcontroller: ATMEGA328P.  Is that any help?
Logged

California
Offline Offline
God Member
*****
Karma: 14
Posts: 629
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Does your Uno look like this:



or this:



Primary focus is on the black square or rectangle to the right of the USB socket.  If it is rectangular with pins on both sides, it is FTDI.  If it is a square it is either an Atmega8u2 or Atmega16u2.
Logged


Wisconsin
Offline Offline
Edison Member
*
Karma: 4
Posts: 1001
I LOVE THIS STUFF!!!!
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Body feels not good, then go to the hospital for examination, the doctor asked X-rayed, Cheap GW2 CD Keys
X-ray, MD wrote diagnosis, and then I took the diagnosis and film to the doctor. Surprisingly, the doctors took X-ray diagnosis began shaking his head,  his mouth Gee, I was immediately pumped wow cool, want to ask the doctor left how long results that doctors say is: "Oh, now young doctors, the handwriting is really bad. "
Diablo 3 Gold



In all my days, I have never had quite a period of wtf as I just did.
Logged

Accelerate to 88 miles per hour.

Offline Offline
Newbie
*
Karma: 0
Posts: 5
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

snip
Primary focus is on the black square or rectangle to the right of the USB socket.  If it is rectangular with pins on both sides, it is FTDI.  If it is a square it is either an Atmega8u2 or Atmega16u2.

My Uno looks like


The chip to the right of the USB socket is square, so I don't need the FTDI Drivers, I'm assuming.

Thanks for the continued assistance.
Logged

California
Offline Offline
God Member
*****
Karma: 14
Posts: 629
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Do you have a USB hub handy (thingy that plugs into the USB and splits off 3 or 4 other ports)?  I am not sure how the MacOS handles the Hub, but with Windoze, it assigns another device and starts the installation process again.  Make sure you have proper permissions (User Account with Admin rights).
Logged


USA
Offline Offline
Newbie
*
Karma: 0
Posts: 1
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
I solved this problem by selecting a different board. I have an Uno R3 Plus. However, it is an OEM board which means different chips. I was able to get it to work by selecting the Duemilanove ATmega328. works fine now.

Thanks, that solved the problem for my Arduino Uno R3 + Mac combination!
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 1
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

My problem was that I previously installed the FTDI drivers on my MAC even though I was working with an Arduino Mega (Which does not need those drivers) . Apparently  the arduino program was using those drivers to communicate with my Mega that is why in Tools-Port I had tty-USBSerialxxx. I uninstalled those drivers and I got tty.usbmodem1411. My arduino MEGA ran perfectly fine. I hope this helps smiley
Logged

Pages: 1 [2] 3   Go Up
Jump to: