Pages: 1 2 [3]   Go Down
Author Topic: Arduino 1.0.1 causes Mac OS X to crash regularly. Ideas?  (Read 34220 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 7
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

After posting the last message, I updated to IDE version 1.0.5.  It took 25 or 30 uploads before my Mac crashed, but it did crash.  At the time of the crash, Chrome was not running, but other USB devices were connected and iTunes was running.  Also, it crashed uploading to a Leonardo.  As before, the panic report did not show anything interesting.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 3
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hello,

the same problem has been biting me for a while now, with various versions of the Arduino IDE on a late 2009 MBP running Snow Leopard first and now Mountain Lion. I only use official Arduine so far, Uno and Leonardo. Both exhibit the behavior. It usually happens after a couple of uploads to the board. The Mac freezes for a few seconds (including mouse pointer and everything), then goes to a grey "sorry,there was a problem" screen, then reboots. I find it extremely annoying, since I regularly lose unsaved data due to this. Any possible workaround is greatly appreciated.

Best regards,
Joerg
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 3
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

The same happens to me with all these combinations:
macbook 17 early 2009
Osx 10.9 (but it was the same on the old one)
Arduino 0.22 / Arduino 1.0.x
ARDUINO MEGA2560 AND ONE R3 via USB
my custom atmel atmega328P chip based via USB2SERIAL
Oracle Java 7 / Open JDK 7 / Open JDK 6
Crash after some uploads, during upload. I'm working on arduino for three years. This time I upgraded several osx versions and my feeling is that it depends on osx upgrades. Infact in this period I've kept stable ide (0.22) and hardware, but only upgraded OSX, and it seems to be worse and worse.
What about Arduino Team? Are they investigating about it? I think also that it should be related with RXTX native of java, but I think that it could be also caused by some bug in the IDE.
bye
Paolo



Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 3
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Dears,
I found a trick to avoid OSX to crash... simply use a USB hub to connect to arduino. I've done this and it stop crashing.
Hope this helps someone.
bye
Paolo
Logged

SF Bay Area (USA)
Offline Offline
Tesla Member
***
Karma: 137
Posts: 6792
Strongly opinionated, but not official!
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Ah.  Was it a USB 3.0 port that you were connecting to?  That would explain why so many people weren't seeing the problem.
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 1
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Exactly the same to me.
With OSX 10.7 it works fine.
Just since I changed to 10.9  kernel panic accour regularly while uploading.
(Today it crashed the HD or better something of the "user" ... so I had to restore startdisc to be able to login again.)

Anoying!

1) Will test it by using an external USB Host. If it is the USB voltage supply
2) Will check usb drivers.
Logged

Berlin
Offline Offline
Newbie
*
Karma: 0
Posts: 1
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

This is my first post here and I'd like to say Hello to everybody in the Arduino world! And I would like to say, that my English could be better, but I think it's ok.

I looked for a solution for the problem, that Mac OS-X crashes. So I found this thread. I've a late 2008 Macbook (first 13" unibody), running "Maverick". Even by using the suggested USB-Hub the macbook crashes completely and does only start again after plugging off the Arduino (Arduino Uno R3). But I do also have a late 2010  11" MacbookAir also running Maverick. And there I do not have the crash problem after several hours of using until now.

This post may not be very helpful to solve the problem actually, but it shows, that the same Arduino-hardware and software (1.0.5) can cause crashing a macbook or run stable.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 1
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi,

I seem to be having crashes on osx with Maverics on a 13" mid 2009 unibody while uploading to arduino.
Here's a message (attached) I get on screen after a hard reset.


* IMAG0208.jpg (1319.55 KB, 2592x1552 - viewed 62 times.)
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 1
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi All

I have also been having problems with version 1.0.5 on Mavericks on a 2010 Air. I'm using a genuine Leonardo.

There seems to be two different issues:

1. Serial data. When sending lots of data from the board to the mac using the serial monitor the mac will lock up without giving me a grey screen. Mouse moves and that's about it. If I use screen or a third party terminal this is not an issue.

2. Programming / Compiling. As mentioned earlier when doing frequent uploads I have had the mac crash and give me a grey screen. Happened 3 times in 15 minutes yesterday evening. (See pic in previous post).

In normal day to day use my mac is reliable and does not have any issues.

I have 2 questions, what is the best method of getting these issues resolved, and is there an alternative development environment?

Thanks

Glen
Logged

0
Offline Offline
Jr. Member
**
Karma: 0
Posts: 63
Arduino rocks / OpenLCB rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I just received an email yesterday from the Arduino group regarding this:
 
    "JSSC has been released wih 1.5.6, this problem should be fixed now."

David
Logged

Dr. David Harris
OpenLCB Dev Team

Offline Offline
Newbie
*
Karma: 0
Posts: 1
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

   "JSSC has been released wih 1.5.6, this problem should be fixed now."



Hi All,

I am new to this forum. I have the same problems once in a while when uploading a sketch from my iMac (Mid 2010) to an (official) Arduino UNO (Rev 3) board. What do I have to do? Do I need to switch from version 1.0.1 of the IDE to version 1.5.6?  As I already installed this a couple of months ago - do I have to re-install it? Any suggestions are highly appreciated.

Thanks,

Hj
« Last Edit: March 01, 2014, 05:13:17 pm by MaFreha » Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 1
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

My symptoms were pretty much identical to what has already been reported in this thread.
After suffering a couple of computer crashes today,  I upgraded to Arduino IDE 1.5.6-r2.   
So far, I haven't been able to provoke any crashes. 
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 2
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

People would be screaming if the normal Arduino IDE crashed the entire computer every hour. It just doesn't.

I'm running a Sunfounder Mega 2560 using Arduino 1.0.5 on my Mac (Mavericks) and I've crashed my system twice this morning when clicking to upload to the arduino.  smiley-sad
Logged

0
Offline Offline
Jr. Member
**
Karma: 0
Posts: 63
Arduino rocks / OpenLCB rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I continue to have crashes on my Mac Book Pro with Arduino and Energia -- these occur when my program generates too much serial traffic.  Perhaps I should try a third party terminal program instead of the IDE one. 

David
Logged

Dr. David Harris
OpenLCB Dev Team

Pages: 1 2 [3]   Go Up
Jump to: