Go Down

Topic: Arduino 1.0.1 causes Mac OS X to crash regularly. Ideas? (Read 44379 times) previous topic - next topic

Ardinator

Each Mac that I own (not just the Arduino program, but the whole OS) crashes about once per hour when I try to use Arduino 1.0.1. I can't go back to Arduino 1.0 because I need the Keyboard routines. I own two separate Stealthduino boards (http://cal-eng.com/?wpsc-product=stealthduino-atmega328) and it happens to each of them on each of my Macs no matter which USB port I'm plugged into. In my mind that points towards an error in the Arduino 1.0.1 software. Or is there another explanation?

James C4S

Maybe it's an issue with the 2102s driver.

I, and many many others, with official Arduinos do not have a problem with Macs.
Capacitor Expert By Day, Enginerd by night.  ||  Personal Blog: www.baldengineer.com  || Electronics Tutorials for Beginners:  www.addohms.com

Ardinator

Since I'm new to using Arduino devices, may I ask if you are talking about a driver on the Mac or a driver on the Arduino chips? I've never installed drivers for the Mac. As a result I can't tell if you're implying it's the device or if it's the Arduino software.

Nick Gammon

What Mac/ OS/X version are you using? I do all (almost) all of my Arduino work on a Mac, and it crashes virtually never (maybe once a month).  And that includes 1.0.1 of the IDE.
Please post technical questions on the forum, not by personal message. Thanks!

More info:
http://www.gammon.com.au/electronics

eried

My website: http://ried.cl

James C4S


Since I'm new to using Arduino devices

You aren't using an Arduino.


may I ask if you are talking about a driver on the Mac or a driver on the Arduino chips?

there is no such thing as "Arduino chips."

The board you are using, is based on the Silicon Labs CP2102 serial to USB chip.  No official aduino uses this chip for USB.  I suggest you contact the person who sold you the board for support.
Capacitor Expert By Day, Enginerd by night.  ||  Personal Blog: www.baldengineer.com  || Electronics Tutorials for Beginners:  www.addohms.com

Louis Davis

You should probably get the latest drivers from Silabs here:
http://www.silabs.com/products/mcu/Pages/USBtoUARTBridgeVCPDrivers.aspx

Nick Gammon


In my mind that points towards an error in the Arduino 1.0.1 software.


In my mind it points to an error in the only thing that is different from the normal Arduino IDE.  From their web page:

Quote
No modifications of the Arduino environment are needed, simply install the SiLabs USB drivers ...


Oops. A modification to the environment. Device drivers typically need access to low-level operating system functions. People would be screaming if the normal Arduino IDE crashed the entire computer every hour. It just doesn't.
Please post technical questions on the forum, not by personal message. Thanks!

More info:
http://www.gammon.com.au/electronics

Ardinator

Here are the answers to the questions below. I am using Lion, OS/X 10.7.4. I am using the English version of the Arduino program. I did contact the company owner and he hasn't replied yet, probably because I told him I was posting my question here too. His website says on the link I gave previously that some operating systems may not need USB drivers. And he told me in person that Macs don't need drivers. But in any case because I want to try everything suggested here I did download the drivers, and that didn't solve my problem. Moreoever, I haven't needed drivers for the last six months using Arduino software 1.0. So I can't understand why v1.0.1 would suddenly need drivers. I'm open to changing to another device if nobody knows why v1.0 works but v1.0.1 doesn't work. Any suggestions for a new device? Something simple that plugs into a USB port preferably.

Nick Gammon

The driver page linked to does in fact have OS/X drivers. The release notes for OS/X say, amongst other things:

Quote

Version 2.6
   Corrected all known Kernel Panics for 10.4/5/6 for surprise removal and data
   transmission
   Corrected an issue with data drop while using XON/XOFF flow control
   Corrected RTS/DTR toggling sync issue
   
Version 2.2
   Corrected Kernel Panic in Snow Leopard which would randomly occur after
   transmission


(my emphasis)
Please post technical questions on the forum, not by personal message. Thanks!

More info:
http://www.gammon.com.au/electronics

Ardinator

Nick you are a smart guy and I appreciate your help, and I'm sorry if I upset you. Nonetheless may I point out that drivers were never necessary under Arduino software v1.0. I've been using v1.0 for six months with no drivers and no problems. So if you think I need to install drivers, why weren't drivers required under Arduino software v1.0? That is puzzling me. But in any case I did install the drivers today and they made no difference. That is, the device is still not visible to the Arduino 1.0.1 software although I haven't seen a crash yet, but it usually takes an hour for a crash.

The following things happened when the crashes began:

1. Updated Arduino software from 1.0 to 1.0.1
2. Mac OS/X often has minor patches applied automatically, so I can't rule that out.
3. I bought a new Stealthduino from the website because the old one apparently needed a firmware upgrade to work with 1.0.1. By purchasing a new Stealthduino I wouldn't need to apply the firmware upgrade. But I got the old one upgraded anyway by the company and that one won't work either now.

I called it a "firmware upgrade" but the truth is I'm not sure if "firmware" is the right word. I'm new to Arduino technology so I'm not sure if it's firmware, microcode, or something else. Again, I admit I'm quite ignorant here.

Is anyone willing to suggest a product that I could use instead of this one? My wish is that the device plug into my USB port without me having to to any hardware modifications like soldering or jumpers or suchlike, as I don't have hardware tools. Most of the Arduino things I've seen online require an experienced hardware guy to build around them. I'm not knowledgeable enough to do that.

I don't want to go back to v1.0 of the software because I need the Keyboard routines. I was able to hack the v1.0 software to make the Keyboard routines visible but I don't want to have to do that again. However I'm starting to wonder if I did do that would I have the same problem as I'm having now. If not, then it's not the hardware that's giving me the problem. If so, then I think that means it's a software problem, anything from the OS to the Arduino software.

Nick Gammon


Nick you are a smart guy and I appreciate your help, and I'm sorry if I upset you.


I'm not upset. I don't have that device, and was only trying to help based on what I saw on that web site. Sorry it didn't work for you.
Please post technical questions on the forum, not by personal message. Thanks!

More info:
http://www.gammon.com.au/electronics

James C4S


I called it a "firmware upgrade" but the truth is I'm not sure if "firmware" is the right word. I'm new to Arduino technology

The "Arduino Technology" isn't that complex.  It is a PCB with a USB to Serial chip, Voltage Regulator, and ATmega328.  The only "firmware" is the bootloader programmed on the ATmega328 and possibly the USB to Serial Chip, depending on which one is being used.

This isn't a complex PC with hundreds of layers.  It is a simple 8-bit microcontroller board.


Is anyone willing to suggest a product that I could use instead of this one?

One suggestion might be an official Arduino board.  They are well tested and used by a large number of people.  You're working with a board few people use and a USB to Serial chip even fewer people use.  It is difficult to provide much help in that case.


There is no magic to the IDE software.  The only they it might do in the background is poll for what serial ports are available.  Otherwise, it doesn't touch the serial port until you press upload.  It is hard to imagine why you would see this problem with 1.0.1 and not 1.0.  It is more likely a coincidence the problem surfaced after updating.
Capacitor Expert By Day, Enginerd by night.  ||  Personal Blog: www.baldengineer.com  || Electronics Tutorials for Beginners:  www.addohms.com

chriswei

I've been experiencing similar symptoms. I'm using an Arduino UNO R3, and occasionally (and seemingly at random) my MacBook Pro reboots itself. Not the expected kernel panic warning, just an immediate reboot. It happens when I'm uploading code to the Arduino.

It seems to have started with Arduino 1.0.1. I'm running 1.0.2 now and had 3-4 reboots in an hour before giving up.

I'm going to try to go back to 1.0 and see if it continues.

MacBook Pro "Mid 2009", OS X 10.8.2

- Chris

Papa G

I too have been experiencing similar problems. I am using a late 2008 Mac Book Pro with OS X 10.8.2. The boards I am using are the Sparkfun 8 MHz pro-mini in both '168 and '328 versions and a Freetronics EtherTen. The symptoms appeared when I upgraded to 1.0.1 and have continued into 1.0.2. My system reboots after 15 or 20 minutes and only seems to do so when I have a board connected via USB. I haven't been able to duplicate the problem with no board connected.

Go Up