Pages: [1]   Go Down
Author Topic: 150RGB LED mit WS2801 - Dimensionierung des Netzteils  (Read 1723 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 9
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hallo,

ich wollte 150 LEDs von folgendem Typ http://www.watterott.com/de/12mm-RGB-LED-Strang-WS2801 betreiben. D.h. also 6 Stränge.

60mA / 5V pro Pixel.

Durch die Parallelschaltung der Pixel wären das ja am Ende:
60mA/Pixel*150Pixel = 9A

Um beim Netzteil noch etwas Platz nach oben zu haben, wäre also mind. ein 10A Schaltnetzteil sinnvoll.
Ist soetwas z.B. http://www.reichelt.de/Schaltnetzteile-Case-geschlossen/SNT-MW60-05/3/index.html?;ACTION=3;LA=446;ARTICLE=57481;GROUPID=4959;artnr=SNT+MW60-05;SID=10UDVR7n8AAAIAAFj-qgQ593c8a6579db5fb88979a2164e6b06d4 geeignet?

Was mich jetzt verwirrt ist, dass Watterott sagt: "We have a 5V/2A supply that should be able to drive 2 or more strands." Wenn ich jedoch richtig rechne benötigt ein Strang ja schon maximal 1.5A. Oder gehen die davon aus, dass man eh nie alle LEDs gleichzeitig auf volle Helligkeit stellt?

Danke schon mal für eure Hilfe. smiley
Logged

Offline Offline
Jr. Member
**
Karma: 0
Posts: 85
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi

da scheint wohl der Fehlerteufel bei Watterott zugeschlagen zu haben.

Du brauchst die 10A.

Surfemal nach dem 2A Netzteil da ist dann ein Linke auf einen RGB Strip von dem 2 an das Netzteil passen und weiter unten kommst dann wieder auf Deinen Strip nun aber von Adafruit und dort in der Beschreibung ist dann für 160 LED von 10A die Rede.

guckst Du hier: http://www.adafruit.com/products/322
Logged

Forum Moderator
BZ (I)
Offline Offline
Brattain Member
*****
Karma: 257
Posts: 21473
+39 349 2158303
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Ja, alle LED an und weißes Licht: 9A.
Das vorgeschlagene Netzteil Ist für den Einbau in ein Gehäuße mit guter Lüftung gedacht.
Grüße Uwe
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 9
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Eine Aktive Lüftung wollte ich nicht haben. Das adafruit Netzteil gibts leider so nicht in Deutschland.

Ich bin am überlegen, ob ich nicht 3x 5V 3A Netzteile nutze und die LEDs in 50er Blöcke splitte. Sollte ja kein Problem sein, oder?
Logged

Forum Moderator
BZ (I)
Offline Offline
Brattain Member
*****
Karma: 257
Posts: 21473
+39 349 2158303
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Du brauchst keine Aktive Kühlung (Ventilator)  aber in ein Plastikgehäuße einbauen, das keine Küftungslöcher hat, geht auch nicht.

Ja, Du kannst die LED für die Stromversorgung in 3 Blöche einteilen und mit 3x 3A Netzteilen versorgen. Die Masse aller 3 Netzteile zusammenschalten.
 
Grüße Uwe
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 9
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Vielen Dank erstmal für eure Antworten. smiley

Ja, das ganze soll unter einen Tisch. Platz wäre theoretisch genug, weiß nur nicht ob ich ein offenes Netzteil drunter haben will, falls mal eine Flasche/Glas umkippt.

Es scheint aber auch noch in Plastik verpackt verfügbar zu sein:
http://www.reichelt.de/Schaltnetzteile-fuer-Hut-Schiene/SNT-MW-MDR60-05/3/index.html?;ACTION=3;LA=3;ARTICLE=85240;GROUPID=4961


Für die "drei Netzteil"-Variante: Welchen Grund gibt es die Masse zusammenzuschalten? Mir ist klar, dass nicht jedes Netzteil gleich ist, aber auf der Masse sollten doch bei allen von außen gesehen 0V anliegen?

Die LEDs kann ich ja nach jeder LED trennen.



Edit: anders gefragt, macht es überhaupt Sinn 10A über die dünnen Leitungen zu führen? Wäre es nicht möglich und sinnvoller die Datenleitungen durchgehend an den Arduino anzuschließen und je 3 50LED-Stränge seriell zu anschließen?
Wenn ich jetzt richtig aufgepasst habe, müsste dann ja nur noch 1/3 des elektrischen Stroms fließen, also würde ein 15V/3A Netzteil ausreichen.
Oder irre ich mich jetzt?
« Last Edit: September 24, 2012, 10:32:44 pm by mrueg » Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 9
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Folgendes meinte ich mit der 15V/3A Schaltung:

Code:
VCC -[50 LED parallel]-  -[50 LED parallel]-  -[50 LED parallel]- GND


Bei der 3x 5V 3A Schaltung hätte ich ja eher
Code:
VCC  -[50 LED parallel]-
                         \
VCC -[50 LED parallel]- GND -[50 LED parallel]- VCC

Wenn ich ein 5V/10A Netzteil nehme, müsste ich ja trotzdem die Ströme teilen. Denn das Tool [1] gibt mir einen Querschnitt von 1.5mm² aus. Wenn ich mich jetzt nicht verrechnet habe, wäre das ein Durchmesser von 1.3mm, die die Litzen definitiv nicht haben.


Code:
       -[50 LED parallel]-
     /                     \
VCC-  -[50 LED parallel]-   -GND     
    \                      /
      -[50 LED parallel]-



Was haltet ihr denn für die beste Methode?

Gruß
mrueg.

[1] http://fmtool.de/index.php?option=com_content&view=section&id=5&Itemid=75
Logged

Forum Moderator
BZ (I)
Offline Offline
Brattain Member
*****
Karma: 257
Posts: 21473
+39 349 2158303
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Es scheint aber auch noch in Plastik verpackt verfügbar zu sein:
http://www.reichelt.de/Schaltnetzteile-fuer-Hut-Schiene/SNT-MW-MDR60-05/3/index.html?;ACTION=3;LA=3;ARTICLE=85240;GROUPID=4961

Für die "drei Netzteil"-Variante: Welchen Grund gibt es die Masse zusammenzuschalten? Mir ist klar, dass nicht jedes Netzteil gleich ist, aber auf der Masse sollten doch bei allen von außen gesehen 0V anliegen?

Die LEDs kann ich ja nach jeder LED trennen.



Edit: anders gefragt, macht es überhaupt Sinn 10A über die dünnen Leitungen zu führen? Wäre es nicht möglich und sinnvoller die Datenleitungen durchgehend an den Arduino anzuschließen und je 3 50LED-Stränge seriell zu anschließen?
Wenn ich jetzt richtig aufgepasst habe, müsste dann ja nur noch 1/3 des elektrischen Stroms fließen, also würde ein 15V/3A Netzteil ausreichen.
Oder irre ich mich jetzt?

1) das sind keine OLED (Organic LED) sondern normale LED
2) ja, Es ist sinnvoll auch bei einem 5V 10A Netzteil die 5V an verschiedenen Stellen einzuspeisen da die internen Verbindungen des Strips nicht für 10 A ausgelegt sind.
3) Ja es ist auch sinnvoll 3 Stränge mit je 50LED an je ein 5V3A Netzteil oder alle zusammen an ein 10A Netzteil anzuschließen.

Quote
Für die "drei Netzteil"-Variante: Welchen Grund gibt es die Masse zusammenzuschalten? Mir ist klar, dass nicht jedes Netzteil gleich ist, aber auf der Masse sollten doch bei allen von außen gesehen 0V anliegen?

4) Sie Sekundärseite (5V) der Netzteile sind entweder völlig isoliert von der Erde, Über einen Kondensator die Masse (0V) an Erde angeschlossen oder die Masse geerdet. Im ersten Fall mißt Du gar nichts (genaugesagt nur Störungen) wenn du zwischen masse Arduino un Masse oder 5V des Netzteils mißt. Im zweiten Fall mißt Du etwas Wechselspannung. Im dritten Fall, falls Du einen PC mit Netzanschluß (nicht mit Batteriebetrieb) mißt Du irgendeine kleine Wechselspannung. Damit der Arduino Steuersignale senden kann, die die WS2801 auch verstehen muß die Masse des Arduino mit der Masse des Netzteils verbunden sein um einen referenzpunkt für die Spannungspegel zu haben.
Darum muß die Masse des Arduino mit der oder den Massen des bzw der Netzteile verbunden sein.

Quote
Edit: anders gefragt, macht es überhaupt Sinn 10A über die dünnen Leitungen zu führen? Wäre es nicht möglich und sinnvoller die Datenleitungen durchgehend an den Arduino anzuschließen und je 3 50LED-Stränge seriell zu anschließen?
Wenn ich jetzt richtig aufgepasst habe, müsste dann ja nur noch 1/3 des elektrischen Stroms fließen, also würde ein 15V/3A Netzteil ausreichen.
Oder irre ich mich jetzt?
Wenn Du so fragst und eine ehrliche Antwort erwartest: Du irrst Dich gewaltig.
1) wenn du die Stränge in Serie an der Versorgung anschließt muß in allen Strängen der gleiche Strom fließen damit die Spannung sich gleichmäßig aufteilt.
2) die Masse des ersten Stranges ist auf 0V, die des Zweiten auf 5V, die des dritten auf 10V. Die mußt Du aber zusammenschalten damit die WS2801 die 5V Steuerspannung des Arduino als H interpretiert. Das stellt einen Kurzschluß dar und der dritte Strip bekommt 15V anstatt 5V und geht kaputt. (wahrscheinlich auch dann gleish der Arduino weil er 15V an die Ausgänge bekommt.

Grüße Uwe
Logged

Pages: [1]   Go Up
Jump to: