Go Down

Topic: Why can't i visit my arduino's IP address?? It is 192.168.2.7 (Read 413 times) previous topic - next topic

SkyDuino

Hey everyone I've just started on my arduino Ethernet shield and I have set it up already but when I tried the WebServer example, it would show that it is successful but when I try to visit my IP address, it wont show anything. My browser just says "Webpage Not Available". Please help. By the way, my browser is IE and I'm using the arduino Ethernet Shield rev2.

DrAzzy

Have you configured the ethernet shield to act as a server?

Have you verified that it has connectivity?
ATtiny core for 841+1634+828 and x313/x4/x5/x61/x7/x8 series Board Manager:
http://drazzy.com/package_drazzy.com_index.json
ATtiny breakouts (some assembled), mosfets and awesome prototyping board in my store http://tindie.com/stores/DrAzzy

AMPS-N

goto local area setting-> choose port being connected to arduino shield -> right click check properties->

take snap shot of page send us screen shot here. Also try to post your code or link from where you downloaded the program.


i have attached image for reference.
AMPS

Arlove

use this mac adress. 0xDE, 0xAD, 0xBE, 0xEF, 0xFE, 0xED

example my computer ip adress 192.168.1.180

u use ıp adress +3, -3 = 192.168.1.177 or 192.168.1.183


and u can look all ip adress Advanced IP Scanner program.


Code: [Select]
byte mac[] = {
  0xDE, 0xAD, 0xBE, 0xEF, 0xFE, 0xED
};
IPAddress ip(192, 168, 1, 177);

SkyDuino

Have you configured the ethernet shield to act as a server?

Have you verified that it has connectivity?
yes sir I already had

SkyDuino

goto local area setting-> choose port being connected to arduino shield -> right click check properties->

take snap shot of page send us screen shot here. Also try to post your code or link from where you downloaded the program.


i have attached image for reference.
by the way, I am using windows 7
and how do I attach

SurferTim

According to the pic you attached, your ethernet IP should be something like 192.168.1.7 (or 192.168.1.x).

AMPS-N

@surferTim thats reason i am telling to post his IP address , so that manually config ip address.
http://windows.microsoft.com/en-in/windows/change-tcp-ip-settings#1TC=windows-7

check this link . you need to config your arduino Ip address with network ip of pc
AMPS

Go Up
 


Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

Arduino
via Egeo 16
Torino, 10131
Italy