Go Down

Topic: pulling my hair out!!! uln2803apg (Read 1 time) previous topic - next topic


Sep 24, 2012, 08:06 am Last Edit: Sep 24, 2012, 08:08 am by cjdelphi Reason: 1
I bought 10 of these damn toshiba darlington arrays and i can't get a single 1 to behave :((((


to simplify things

it's running off a 5v rail (usb/arduino)

basically.. without gnd it lights dimly with gnd nothing!!! i tried 5ics it's like they all came fried i'm a little worried trying the other 5 incase i'm blowing them somehow?!?


Nick Gammon

I didn't understand any of that. What "toshiba darlington arrays"? Part number? Link to data sheet?

it's running off a 5v rail (usb/arduino)

What circuit?

What code? Or isn't that relevant?
Please post technical questions on the forum, not by personal message. Thanks!

More info:


You need to connect PIN10 to VCC.


Nick - re read the title :p

the pictures are of the circuit.. all im doing is making sure these ics work

Ok ill try that lavan cheers




just to add, I ran into an opposite problem when I connected this to an 8 channel relay board, which already comes with its own diode circuit connected to supply rail. In my case, I connected pin 10 to Vcc and was getting unpredictable results, until I disconnected pin 10.

Go Up

Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

via Egeo 16
Torino, 10131