Go Down

Topic: Nano Strange things happening (Read 571 times) previous topic - next topic

Fivetide

I have a Nano ATMega328 in fact I have 2, I ran a  simple servo sweep program on it just to test it and it has a strange habbit of making the USB connect and disconnect sound after each command. Also I have a 2 server sketch with a processing mouse interface that works perfectly ok on my UNO and Mega but wont run at all via the Nano , exacly the same setup.. anyone any ideas ? And I have also tried it with the  2nd nano and a lower power set of micro servos still same result. Just another thing, when I plug the nano in it goes to com4 my uno and mega run on 3 and it says installing USB serial converter and in devices thats what is displayed.

Chagrin

More than likely the servos are sucking too much power and causing the Nano to reset.

See: http://rcarduino.blogspot.com/2012/04/servo-problems-with-arduino-part-1.html

Fivetide

I think your totally right , thanks for the link :)

MarkT

USB power is not enough for servos - the computer USB hardware will be detecting over-current draw on the USB power and disconnecting automatically, the software drivers note this error condition and probably retry to establish the link some short time later.

Assume every servo can pull spike currents of a few amps and design accordingly.  Almost always a bad idea to share power to a servo or motor with a microcontroller.  In fact ~90% of posting on servos here are because of this.
[ I won't respond to messages, use the forum please ]

Go Up