Pages: [1]   Go Down
Author Topic: Not happy 1.0 to 1.0.1 :(  (Read 1100 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Edison Member
*
Karma: 29
Posts: 2370
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

In file included from WebServer.cpp:1:
C:\arduino\arduino-1.0.1\libraries\SPI/SPI.h: In static member function 'static byte SPIClass::transfer(byte)':
C:\arduino\arduino-1.0.1\libraries\SPI/SPI.h:56: error: 'SPDR' was not declared in this scope
C:\arduino\arduino-1.0.1\libraries\SPI/SPI.h:57: error: 'SPSR' was not declared in this scope
C:\arduino\arduino-1.0.1\libraries\SPI/SPI.h:57: error: 'SPIF' was not declared in this scope
C:\arduino\arduino-1.0.1\libraries\SPI/SPI.h: In static member function 'static void SPIClass::attachInterrupt()':
C:\arduino\arduino-1.0.1\libraries\SPI/SPI.h:63: error: 'SPCR' was not declared in this scope
C:\arduino\arduino-1.0.1\libraries\SPI/SPI.h:63: error: 'SPIE' was not declared in this scope
C:\arduino\arduino-1.0.1\libraries\SPI/SPI.h: In static member function 'static void SPIClass::detachInterrupt()':
C:\arduino\arduino-1.0.1\libraries\SPI/SPI.h:67: error: 'SPCR' was not declared in this scope
C:\arduino\arduino-1.0.1\libraries\SPI/SPI.h:67: error: 'SPIE' was not declared in this scope
WebServer.cpp: At global scope:
WebServer:41: error: 'A0' was not declared in this scope
WebServer.cpp: In function 'void setup()':
WebServer:75: error: 'A5' was not declared in this scope
WebServer:77: error: 'Serial' was not declared in this scope
WebServer:81: error: 'A4' was not declared in this scope
WebServer.cpp: In function 'void loop()':
WebServer:129: error: 'Serial' was not declared in this scope
WebServer.cpp: In function 'void CheckLightLevels()':
WebServer:161: error: 'A1' was not declared in this scope
WebServer:163: error: 'Serial' was not declared in this scope
WebServer.cpp: In function 'void ExternalLightSwitch()':
WebServer:317: error: 'A4' was not declared in this scope
WebServer.cpp: In function 'void CheckChar(char)':
WebServer:601: error: 'A5' was not declared in this scope
WebServer.cpp: In function 'void rstbt()':
WebServer:679: error: 'A5' was not declared in this scope


A0 - A5 - where did my analog inputs go!?

if i can't access Analog 0 with A0, what do i use now?

smiley-sad
Logged

Global Moderator
Dallas
Online Online
Shannon Member
*****
Karma: 200
Posts: 12779
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset


Which board do you have selected?
Logged

Offline Offline
Edison Member
*
Karma: 29
Posts: 2370
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Arduino Dum (month in italian) olvio board.

It started happening after i installed the ATTiny 45 hardware folder to be honest... strange thing is, i can't communicate with the ATTiny chips as an ISP (different question for a different forum area)


... A1 has gone, what do i need to use 13? 14?
Logged

Global Moderator
Dallas
Online Online
Shannon Member
*****
Karma: 200
Posts: 12779
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset


For boards based on the ATmega328 A0 is pin 14, A1 is pin 15, etcetera.
Logged

Offline Offline
Edison Member
*
Karma: 26
Posts: 1339
You do some programming to solve a problem, and some to solve it in a particular language. (CC2)
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
A0 - A5 - where did my analog inputs go!?

if i can't access Analog 0 with A0, what do i use now?

Maybe analogRead(0) ?
« Last Edit: September 27, 2012, 03:56:58 am by Nick Gammon » Logged

Offline Offline
Edison Member
*
Karma: 29
Posts: 2370
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset


For boards based on the ATmega328 A0 is pin 14, A1 is pin 15, etcetera.

Thanks for the work around! (adding the ATTiny folder in the hardware folder of Arduino, kills the constants A0-A5 etc, annoying)

Logged

Global Moderator
Dallas
Online Online
Shannon Member
*****
Karma: 200
Posts: 12779
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

adding the ATTiny folder in the hardware folder of Arduino, kills the constants A0-A5 etc, annoying

Shouldn't.  Were I in your shoes I would reinstall the IDE.
Logged

Pages: [1]   Go Up
Jump to: