Pages: 1 [2] 3   Go Down
Author Topic: Arduino busted. Want to help a lost soul to understand what part of it broke?  (Read 2232 times)
0 Members and 1 Guest are viewing this topic.
Leeds, England
Offline Offline
God Member
*****
Karma: 14
Posts: 596
Quick, chuck it in the bin before the boss finds out...
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

It's only a small point, but if you updated your location it may help. There are some very knowledgeabe people in your part of the world (continent!) and they may be able to offer advice on obtaining parts.
Logged

Beginners guide to using the Seeedstudio SIM900 GPRS/GSM Shield

argentina
Offline Offline
Newbie
*
Karma: 0
Posts: 31
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

dannable: thanks for the tip. doing it now
Logged

California
Offline Offline
God Member
*****
Karma: 14
Posts: 629
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

That is fascinating, I have an R3 and there is nothing back there.  Lets skip that as I carefully went through the instructions and they stink.

Ok, first thing to do is download and install FLIP (I am assuming you are running Windows or Linux).
After FLIP is installed, plug in your Uno to the USB.
Short the pins 5 & 6 on the Atmega8u2:
http://arduino.cc/en/uploads/Hacking/Uno-front-DFU-reset.png
This should initiate a "New Device Detected" event, manually select the driver folder from the Programs Files\ATMEL\FLIP 3.4.7\USB
(Should install the Atmega8u2 driver and it will require a reboot)
After rebooting, open the FLIP 3.4.7 program and click the Chip Icon and select the Atmega8u2 and click OK.
Now, click the USB Cable and click "Open".

If you get this far, get a screenshot and post it here.
Logged


argentina
Offline Offline
Newbie
*
Karma: 0
Posts: 31
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

It is showing signs of beign ALIVEEEE bahahaha
i've come as far as you said, installed the driver and i think im ready to run the flip software.
heres a screenshot of the device manager

by the way: the 4 and 5 pins correspond to the two pins on the icsp header closest to the usb on my board. check the picture for reference


* devicemanager.png (7.19 KB, 338x126 - viewed 13 times.)

* 8u2resetpins.jpg (1435.02 KB, 2560x1920 - viewed 13 times.)
« Last Edit: September 30, 2012, 08:12:16 pm by rangua » Logged

argentina
Offline Offline
Newbie
*
Karma: 0
Posts: 31
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Ok, im trying to run the flip software to upload the firmware and i can't get it to work.
I'm using windows now, rebooted, and replugged the arduino uno shorting the 4-5 pins on the 8u2. The device once again shows up as a usb device.

When i open the flip software, it asks me to pick the model of the chip, which i do, and then asks for the communication. At this point i pick usb (the only non-grayed option) and it prompts me with the window on the first pic. When i click Open, it tells me "Could not open USB device".
I tried loading the hex file, and here too i ran into a problem. i copy/pasted it on Notepad++ and saved it as UNO-dfu-8u2.hex, but when i try to load it on the flip it tells me the address is out of range :S
how does this work? smiley-confuse

i had the wrong hex file. Hex file loads up correctly, still no communication smiley-sad


* Flipstumble.png (60.83 KB, 630x530 - viewed 15 times.)
« Last Edit: September 30, 2012, 08:00:06 pm by rangua » Logged

argentina
Offline Offline
Newbie
*
Karma: 0
Posts: 31
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Ok, great news. I was selecting the wrong device (for some reason its AT90USB82 and NOT the ATMega8u2) so now the flip program has come to live smiley-grin
i would just press the big red upload button, but i'd like to hear from you first so i don't do anything stupid. I feel like i'm stepping on thin ice here.
should i erase and blank check first?


* FlipSuccess.png (48.5 KB, 627x526 - viewed 16 times.)
Logged

argentina
Offline Offline
Newbie
*
Karma: 0
Posts: 31
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Oh well. I've come this far but i guess not further.
The 8u2 chip seems to be working fine, yet i can't communicate with the arduino. I think the 328p is really damaged, so ill have to find a way to flash the bootloader. If that won't work then it's really fried and i'll have to get another 328p chip.
Anyhow, I think i've accomplished the objective of this post. I've learned (at least i have a startpoint) to debug an arduino board, so thanks for all the help sp!! smiley
Logged

California
Offline Offline
God Member
*****
Karma: 14
Posts: 629
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Sorry for the delay.  The last screenshot is what I wanted to see.  Now, if you pull from your chip (Red Arrow) it will initialize things.  Then, goto File -> Load Hex File then to Arduino-1.x.x\hardware\arduino\firmwares\ and UNO-dfu_and_usbserial_combined.hex file.  When that loads, you should be ready to hit the "Run" button in the Operations pane.  We have to use the "combined" file or we will lose the USB programming ability.
Logged


argentina
Offline Offline
Newbie
*
Karma: 0
Posts: 31
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

hey, i didnt initialize things as you said. i just got the hex file from the web, and i could hit run. After that i unplugged/plugged the arduino and i still couldn't communicate with it.
I've just found an atmega328p with the arduino bootloader in my city smiley-grin
i should get my new chip on a few days, and then i'll try flashing the old 328p. If that won't work then i'll have to believe it's fried. Maybe the capacitor check wasn't so reliable, tomorrow ill buy some leds and i should know for sure.
Logged

California
Offline Offline
God Member
*****
Karma: 14
Posts: 629
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Cool deal.  The FLIP was just something to play with if the Atmega8u2 was behaving.  Good luck on the new chip.
Logged


argentina
Offline Offline
Newbie
*
Karma: 0
Posts: 31
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

at least now i'm more confident that if i just replace the 328p it will all work again. Thanks again for all the help
Logged

argentina
Offline Offline
Newbie
*
Karma: 0
Posts: 31
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

aw man! i've bought the 328p and put it on my board. I still can't communicate with it smiley-sad
i've checked the device manager and posted the screenshot of the error im getting..
what could it be? the 8u2 is working fine according to FLIP... :/


* devicemanager2.png (26.99 KB, 415x457 - viewed 12 times.)
Logged

California
Offline Offline
God Member
*****
Karma: 14
Posts: 629
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

It does not appear that the firmware installed onto the 8u2.  I would suggest running FLIP again and load the hex file into the buffer and post the screenshot of it here before pressing the run button.
Logged


argentina
Offline Offline
Newbie
*
Karma: 0
Posts: 31
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

there goes the hex file.

* 8u2-firmware.hex (0.04 KB - downloaded 6 times.)
Logged

California
Offline Offline
God Member
*****
Karma: 14
Posts: 629
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Try using this:

* UNO-dfu_and_usbserial_combined.hex (17.5 KB - downloaded 9 times.)
Logged


Pages: 1 [2] 3   Go Up
Jump to: