Pages: [1]   Go Down
Author Topic: sensor LM35 retornando valor negativo  (Read 848 times)
0 Members and 1 Guest are viewing this topic.
Uberlandia, MG - Brazil
Offline Offline
Newbie
*
Karma: 0
Posts: 12
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Pessoal,

Estou aprendendo sobre o arduino... cheguei naquele ponto de aprender a usar o sensor de temperatura LM35

Beleza, funciona tudo bem.. ele le os valores... so que do nada, derrepende de 30, ele comeca a retornar pela serial -30

e fica nessa de mandar valor negativo....

nao... nao esta tao frio assim...

é normal ele fazer isso? devo converter tudo p/ positivo? tem alguma funcaozinha que ja faz isso?

Grato,
Tesso M .Costa
Logged

Portugal
Online Online
Edison Member
*
Karma: 27
Posts: 1420
Tomorrow I will know a BIT more than yesterday
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

A minha bola de cristal está avariada e nao estou a conseguir ver o teu codigo  smiley-mr-green
Posta ai
Logged

Debian,Mint,Ubuntu
Arduino Mega 2560
Arduino Nano
Arduino Duemilanove
MAC OS Montain Lion
Raspberry PI Model B


Uberlandia, MG - Brazil
Offline Offline
Newbie
*
Karma: 0
Posts: 12
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

o fonte é simples...
http://pastebin.com/AR8ieXMb

to suspeitando que seja algum mal funcionamento no sensor... pois é bem esporadico esse problema, tem hora que do nada comeca a soltar valor negativo.. tipo de 30 para -30
Logged

Brazil
Offline Offline
Newbie
*
Karma: 0
Posts: 16
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Tive um problema parecido com esse, mas era um LM335 (e nao o LM35) que retornava o valor em Kelvin, ai tinha que converter para Celsius...
Logged

Pages: [1]   Go Up
Jump to: