Go Down

Topic: Installation sous Mageia Linux (Read 897 times) previous topic - next topic

SPC89

Bonjour,
J'ai installé un rpm arduino.

Si je lance l'interface de programmation, on me demande dans quel dossier je veux travailler puis plus rien, la fenêtre ce ferme.

En console cela donne :

[sylvain@localhost ~]$ arduino &
[1] 2924
[sylvain@localhost ~]$ java.lang.UnsatisfiedLinkError: no rxtxSerial in java.library.path thrown while loading gnu.io.RXTXCommDriver
Exception in thread "main" java.lang.UnsatisfiedLinkError: no rxtxSerial in java.library.path
        at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1681)
        at java.lang.Runtime.loadLibrary0(Runtime.java:840)
        at java.lang.System.loadLibrary(System.java:1047)
        at gnu.io.CommPortIdentifier.<clinit>(CommPortIdentifier.java:83)
        at processing.app.Editor.populateSerialMenu(Editor.java:996)
        at processing.app.Editor.buildToolsMenu(Editor.java:698)
        at processing.app.Editor.buildMenuBar(Editor.java:483)
        at processing.app.Editor.<init>(Editor.java:205)
        at processing.app.Base.handleOpen(Base.java:700)
        at processing.app.Base.handleOpen(Base.java:665)
        at processing.app.Base.handleNew(Base.java:561)
        at processing.app.Base.<init>(Base.java:301)
        at processing.app.Base.main(Base.java:190)


Visiblement un problème java et interface série (RXTX) pourtant un premier démarrage m'a demander l'ajout (je ne sais pas quoi) à un groupe. Désolé de ne pas être plus clair.

Si quelqu'un sait ?

Sylvain.

skywodd

Bonjour,

Il manque la librairie RxTX qui gére les ports série au "PATH" de java.
http://rxtx.qbang.org/wiki/index.php/Installation_on_Linux#Installing_RXTX
Des news, des tuto et plein de bonne chose sur http://skyduino.wordpress.com !

SPC89

Merci,
mais la première commande me retourne :
configure: error: Make sure java is in your path before running configure

La suite du document indique bien quelque chose avec JAVA_HOME mais je n'y comprend pas grand chose.

Sylvain.

SPC89

Bon en fait il semblerait qu'il y avait un bug dans les paquets de ma distribution. Sur la liste maegia on m'a dirigé vers https://bugs.mageia.org/show_bug.cgi?id=6181
où j'ai trouvé la solution en installant les rpms de la source blogdrake.net
Sylvain.

anv

#4
Jun 22, 2013, 05:21 pm Last Edit: Jun 22, 2013, 06:49 pm by anv Reason: 1
Dans ce post, vous trouverez un paquet spécialement conçu pour Mageia3. En ftp.blogdrake.net il ya aussi une version pour Mageia 2.
Please see http://forum.arduino.cc/index.php?topic=172877.0

68tjs

Quote
pourtant un premier démarrage m'a demander l'ajout (je ne sais pas quoi) à un groupe.

Je suis sous Debian.
Le groupe doit être "dialout" qui gère les autorisations d'accès à l'USB.
Cela n'a rien à voir avec l'absence de RxTx .

Go Up