Pages: [1]   Go Down
Author Topic: After burning bootloader UNO won't take new code via USB  (Read 922 times)
0 Members and 1 Guest are viewing this topic.
Canby, OR
Offline Offline
Full Member
***
Karma: 1
Posts: 158
Arduino rocks
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

I picked up a usbasp from Ebay for $4, and was playing with it and my Uno. I was able to upload code to my board via the IDE (upload via programmer), etc. Just for testing I did "burn bootloader" and after a long time it appears to have worked. It reverted to the standard "blink" sketch that comes on new Arduinos.

But now I can't upload any sketches to it via USB/Serial. The Uno is recognized by the OS, I get /dev/ttyACM0 but it won't take new code. It returns:

Code:
avrdude: stk500_recv(): programmer is not responding

every time I try and program it via USB. I also tried Windows, and I get the same thing. COM3 is detected, but it won't take code.

Do I need to reprogram the USB chip also? Can I do that with the IDE?
Logged

California
Offline Offline
God Member
*****
Karma: 14
Posts: 629
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Which board bootloader did you burn?
Logged


Canby, OR
Offline Offline
Full Member
***
Karma: 1
Posts: 158
Arduino rocks
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Good question... I presume the Uno? How do you pick? I'm guessing it's just based on which "board" you have selected in the drop down?
Logged

California
Offline Offline
God Member
*****
Karma: 14
Posts: 629
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
Good question... I presume the Uno? How do you pick? I'm guessing it's just based on which "board" you have selected in the drop down?

Yup.  You need to pick the board type and the programmer type.  Are you using SLOW_CLK on the USBasp?
Logged


Canby, OR
Offline Offline
Full Member
***
Karma: 1
Posts: 158
Arduino rocks
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

I'll try it again tonight and let you know. How do I set SLOW_CLK on the USBasp? What does that even do?
Logged

California
Offline Offline
God Member
*****
Karma: 14
Posts: 629
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

It basically slows the upload speed for cranky chips.  Sometimes it helps.  It is located on the jumper header with Target Power and Self Programming.
Logged


SF Bay Area (USA)
Offline Offline
Tesla Member
***
Karma: 124
Posts: 6652
Strongly opinionated, but not official!
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
I did "burn bootloader" and after a long time it appears to have worked. It reverted to the standard "blink" sketch that comes on new Arduinos.
The "burn bootloader" command does NOT burn the "new arduino" blink sketch.  You should have only a bootloader, which should give you three quick blinks immediately after reset, followed by nothing...
Logged

Mobile, AL
Offline Offline
Sr. Member
****
Karma: 0
Posts: 314
CAUTION!-Slow Learner
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Scott, I've been playing with a similar situation today.  Let's be sure we're all on the same page.

1. you have the UNO board with ATmega328P chip.
2. You have UNO selected as the board type from IDE pull-down menu.
3. You connected the USBASB programmer with a blank m328 chip in place with USB cable connected to PC & USBASB selected as programmer type in IDE.
4.  You selected the "Burn bootloader" option from IDE drop-down menu, while it took a while, it did complete with no errors showing in the space below?
5. You place this chip in the UNO board, and connect to PC via USB port and have COM3 selected for UNO board. (is this when the UNO board LED is blinking as if the "Blink" sketch were loaded?  If so, something isn't right - burning bootloader should have left chip clean and ready for a sketch to be loaded.
6. You load sketch "Blink" to UNO board with IDE and then is when you get the "avrdude: stk500_recv(): programmer is not responding" error msg?

That error msg almost sounds more like a msg from avrdude rather than from inside the Arduino IDE????  Other folks will have much more knowledge about solving problems, I just have problems that need solving {grinning} - hoping this will help clear exactly steps taken.

Good luck,
Ken H>
Logged

Denver, CO USA
Offline Offline
Newbie
*
Karma: 0
Posts: 1
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I found the problem to be related to uploading a sketch (from the programmer) after burning the bootloader. 

How I fixed this was to NOT upload a sketch from the programmer after burning the bootloader.  Remove the chip from the programmer and put it back in the UNO, then upload the sketch to it.   
Logged

Left Coast, CA (USA)
Offline Offline
Brattain Member
*****
Karma: 361
Posts: 17263
Measurement changes behavior
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I found the problem to be related to uploading a sketch (from the programmer) after burning the bootloader. 

How I fixed this was to NOT upload a sketch from the programmer after burning the bootloader.  Remove the chip from the programmer and put it back in the UNO, then upload the sketch to it.   


That is correct behavior. Uploading a sketch via ICP hardware programmer results in the sketch being loaded AND any prior bootloader code to be erased.

Lefty
Logged

Pages: [1]   Go Up
Jump to: