Go Down

Topic: FTDI non funziona (Read 1 time) previous topic - next topic

BrainBooster

non aggiungere incognite ai problemi... non collegare nulla sull'arduino finchè non sei sicuro che tutto funzioni (almeno su arduino).

ttcorse

Dimenticavo la cosa piu' importante, la scheda funziona, pero' è dotata di una gui per cambiare alcuni parametri e non funziona piu' nemmeno quella perche non c'è dialogo con la usb

ttcorse

Puo essere che involontariamente quando ero conesso ho dato upload boot e mi ha cancellato il boot?
Come posso fare a rimettere il boot, o a risettare il processore in maniera da ripartire da zero?
La scheda è questa : http://www.rcgroups.com/forums/showthread.php?t=1551599

ttcorse

Adesso sono sicuro che è la ftdi, un amico mi ha prestato la sua e tutto funziona.
Vorrei provare a reinstallare il bootloader della ftdi, sapete come si procede?
grazie mille

astrobeed


Vorrei provare a reinstallare il bootloader della ftdi, sapete come si procede?


Negli FTDI non c'è nessun bootloader, sono ic dedicati alla conversione USB-Seriale, anche se hanno alcuni parametri programmabili non c'è un firmware da caricarci sopra.
Se l'FTDI è danneggiato puoi solo buttarlo via.

BrainBooster

L'ftdi non ha un bootloader, per provarlo fai la prova del loopback.
L'unico modo che hai per caricare il bootloader sul multiwii avendo solo l'ftdi, è il bitbang, ma devi avere accesso anche ad altri pin dell'ic per emulare ICSP.

ttcorse


L'ftdi non ha un bootloader, per provarlo fai la prova del loopback.
L'unico modo che hai per caricare il bootloader sul multiwii avendo solo l'ftdi, è il bitbang, ma devi avere accesso anche ad altri pin dell'ic per emulare ICSP.


Grazie,
La buttero e ne ordino subito una nuova!

Go Up