Pages: [1]   Go Down
Author Topic: Ayuda con configuración de puerto en serie  (Read 497 times)
0 Members and 1 Guest are viewing this topic.
Badajoz, Spain
Offline Offline
Newbie
*
Karma: 1
Posts: 25
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hola a todos,
Estoy haciendo un proyecto en el que se transmiten datos desde una sd a un servidor FTP a traves de GPRS. Para ello estoy usando un atmega644pa a 8mhz (sanguino) al que cargo los programas con un avrisp. El módulo tiene una tasa de transferencia de datos máxima de 85,4 kbps. Viendo los errores asociados a distintas velocidades del uart usando un cristal de 8Mhz veo que la tasa de error varia mucho en función de que el bit u2xn sea 0 o 1. La velocidad que  más interesaría en mí proyecto sería 76800 kbps porque sería la más proxima a la máx teórica del módulo (aunque dudo que en la práctica se pueda alcanzar ese valor en muchas ocasiones). El problema con el me encuentro es que a esa velocidad el uart tiene una tasa de error que varia mucho según la configuración del bit u2xn, siendo esta de un -7% para u2xn=0 y un 0,2% para u2xn=1. Mientras que en el primero de los casos supongo que es inviable una comunicaión fiable, en el segundo si lo es. ¿Cómo puedo saber la configuración de este bit?
Enviando largas cadenas de datos (10 kilobytes) al serial monitor veo que los resultados son muy satisfactorios, lo que me da a entender que este u2xn=1, pero me gustaría saber con certeza su valor.
Gracias por adelantado 
Logged

Pages: [1]   Go Up
Jump to: