Go Down

Topic: Actuator 6V works on PWM, 12V doesn't: aarch ! (Read 2850 times) previous topic - next topic

cvsoft

Hi, I have problems using a 12 V Firgelli actuator. I just started to use arduino.

Code should be fine, it works with the 6V actuator, so I think it's a wiring problem (however the same wiring for 6V works ok)

I drive the actuator (red, ground) from a 12V.
I connect the white wire from the actuator to arduino pin 11.
The arduino board is powered from the same 12V.

This setup works on the 6V actuator, not 12V. Is this somewhere a voltage problem?

Many thanks !

The code:
#include <Servo.h>

Servo s;

void setup() {
  s.attach(11);
}

void loop() {
  s.writeMicroseconds(2000);
  delay(4000);
  s.writeMicroseconds(1000);
  delay(4000); 
}

Grumpy_Mike

Not sure what you mean by this:-
Quote
I drive the actuator (red, ground) from a 12V.
I connect the white wire from the actuator to arduino pin 11.

Do you have three wires?
It does not sound like a good idea to connect anything connected to 12V to an arduino pin unless you know exactly what you have. Any link to this actuator so we can all see?

cvsoft

Here's a picture,

the actuator is firgelli L12-100-100-12-I

Red & Black of actuator goes to 12V
white wire goes to PWM on arduino
Arduino is on 12V, or as in the picture, USB.

I tried to connect the ground of the actuator with the ground of the arduino, no luck.


cvsoft

This is the spec of the actuator:
http://www.firgelli.com/Uploads/PQ12_datasheet.pdf

Grumpy_Mike

The data sheet says nothing about colours so can you describe your setup with the pin numbers.
This can not be connected directly to an arduino. It can not be controlled directly with an arduino.
You need a h-bridge motor driver.

cvsoft

I don't understand - the arduino provides the PWM signal on pin 11, the actuator has a PWM interface. The same interface is used on the 6V which works.

Could I control it with the arduino motor shield r3? (I have one). Thx

Grumpy_Mike

Quote
the actuator has a PWM interface.

Not the data sheet you posted.
Where does it say that?

cvsoft

Sigh, was confused, *this* is the right datasheet.

http://www.firgelli.com/Uploads/L12_datasheet.pdf

I have the 'I' option on page 3.

Grumpy_Mike

Sorry when I click on that I get server not found.

zoomkat

Your "L12-100-100-12-I" per the below from the data sheet probably has the I option for internal analog position feedback. This would usually be an internal pot similar to the pot in a servo. The white wire probably is connected to the wiper on the pot and would output a voltage between the white wire and the black ground wire relative to the position of the actuator. Hopefully you haven't damaged the pot (probably not of the white wire was only connected to an arduino PWM pin)

Quote
S 2-wire open-loop interface (like B option) with limit switching at stroke endpoints.

P Simple analog position feedback signal, no on-board controller.

I Integrated controller with Industrial and RC servo interfaces (see L12 Controller Options section). Not available with 10mm stroke length configurations.

R RC Linear Servo. Not available with 10mm stroke or 12 volts.

L: Mechanical or electrical interface customizations
Custom option codes will be issued by
Google forum search: Use Google Advanced Search and use Http://forum.arduino.cc/index in the "site or domain:" box.

Grumpy_Mike

OK managed to get the data sheet. It seems to say that the I option is available in either the 6V or the 12V version. So it doesn't look like you can use what you want.
Also it says the blue wire is used for PWM input, not the white one.
Make sure the black wire is connected to both the ground of your arduino and the ground of the power supply.
The white wire is used for the current loop input, you can't just connect that to the arduino.

zoomkat

If the output of the white wire is 0-12v, then another high resistance pot could be used as a voltage divider on the white wire output to to reduce the max 12v to 5v for input to the arduino. You will probably need an h-bridge (or relays) to control the actuator motor.
Google forum search: Use Google Advanced Search and use Http://forum.arduino.cc/index in the "site or domain:" box.

cvsoft

Grumy_mike, connecting the ground of the arduino with the black wire did the trick. Thx.

The code posted is not pwm, but servo, so I use the white wire.

zoomkat: only one of my 2  12V actuators do still work, so yes I probably fried something :(.

zoomkat

Quote
zoomkat: only one of my 2  12V actuators do still work, so yes I probably fried something


Well, if you had the below R actuator version, the actuator might act like a servo. You said you hab the I version which doesn't fit with connecting a control signal to the white analog output wire on the actuator. Good luck!

R RC Linear Servo. Not available with 10mm stroke or 12 volts
Google forum search: Use Google Advanced Search and use Http://forum.arduino.cc/index in the "site or domain:" box.

cvsoft

Just fyi, the I version does contain a range of interfaces, also an RC interface.

Go Up