Go Down

Topic: ATmega644 Sanguino with Bootloader has communication failuare with arduino 1.0.1 (Read 1 time) previous topic - next topic

Prakash W Dandekar


I want to run softserial on sanguino ATmega644.  This board uses serial interface using COM1 of desktop PC.  I am not able to download the sketch. I ran following steps.

1. I downloaded arduino 1.0.1

2. Next I downloaded Sanguino-0101r1.zip from:

3. Further, i copied unzipped folder "sanguino" in C:\arduino-1.0.1\hardware.

4. When I started Arduino 1.0.1, I could see under tools->boards->atmega644. I thought that it means I have updated 1.0.1 sucessfully for Sanguino.

5. I tried uploading blink sketch but it did not upload and execute. I got error:
avrdude: stk500_getsync() : notin sync:

6. Same board is working fine with blink sketch on older versions  Arduino-18 and Arduino-22.

In fact I am using this board for last 12 to 13 months.

I feel that somewhere the new Arduino IDE is not perfectly matched to work with sanguino.

Please help.

Thanks in advance.

-Prakash Dandekar

Prakash W Dandekar
Head, Incubation Center, Dean Academic & Professor in Electrical & Electronics Engg.
Swami Vivekanand College of Engg, Khandwa Road, INDORE MP


I feel that somewhere the new Arduino IDE is not perfectly matched to work with sanguino.

What you mean is that Sanguino's modifications are not perfectly matched to work with the Arduino IDE. It is up to third parties to support their modifications. You need to raise this issue with Sanguino.

Go Up

Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

via Egeo 16
Torino, 10131