Go Down

Topic: >> Résolu << : MEGA + lecteur de carte SD "LC studio" ne fonctionnent pas... (Read 6192 times) previous topic - next topic

LibertyCareche

#15
Oct 05, 2012, 10:58 pm Last Edit: Oct 05, 2012, 11:13 pm by LibertyCareche Reason: 1
Oui Jean-François, je l'avais lu. Simplement j'ai commandé le lecteur dont je parle et que j'ai. J'essaye donc d'en faire quelque chose.

Le schéma 1 sans ampli est tangent sur le plan signaux... autant que mon schéma actuel à peu de chose près.
Le schéma 2 est ce qu'il faut sérieusement.

Sinon j'ai lu www.badji.com   mêmes problèmes semble t-il mais je n'ai pas fini la lecture. J'ai commencé comme il le dit avec pin 53 au lieu de 6 mais rien n'y fait...
Ceci étant, je set toujours le pin 53 en out pour la compat SD.h (cf. bout de programme).
Quidquid agis, prudenter agas, et respice finem !

LibertyCareche

Et voilà !! Je pense avoir trouvé le HIC !!  C'est théorique mais en cherchant à reconstituer le schéma de la carte, j'ai vu, et je suis bien obligé de me rendre à l'évidence... que le régulateur est flottant !  Il semble que la masse de ce régulateur ne soit pas connecté à la masse carte. Electronique Chinoise s'il en est !!            Cela pourrait bien expliquer le pourquoi des signaux bizarres... et le prix de cette carte.
Je vais faire une modification de la carte et ré essayer la com.
Quidquid agis, prudenter agas, et respice finem !

Jean-François

MacBook intel core 2 duo  os X snow Leopard 10.6<br/> eMac PPc G4  os X Leopard 10.5<br/>powerbook G4 os X Leopard 10.5
imac PPC G3 os X Pa

LibertyCareche

J'ai de meilleurs signaux et de loin. Je tente une nouvelle adaptation en niveau mais... toujours pas de réponse positive du programme.
Voici des photos de la modif..
.
Quidquid agis, prudenter agas, et respice finem !


LibertyCareche

#20
Oct 06, 2012, 02:07 pm Last Edit: Oct 06, 2012, 02:24 pm by LibertyCareche Reason: 1
oui ... c'est crispant  :)

En même temps, il y a beaucoup,... beaucoup de gens qui parlent mais en pratique... c'est du flanc !! Mais bon... positivons, il y en a surement qui ont fait marcher l'affaire !

Ci-joint les nouveaux scopes
Quidquid agis, prudenter agas, et respice finem !

Snyp

Bon j'ai essayer leur code ça ne marche pas .... que faire.
Car pour mon projet serre si j'utilise le lecteur de carte plus assez de place  :smiley-sleep:

barbudor


. que le régulateur est flottant !  Il semble que la masse de ce régulateur ne soit pas connecté à la masse carte.


Probablement relié à la masse par le pad de dissipation
Barbuduino: Arduino sur Breadboard & VinciDuino: Clone Leonardo // WR703: Mini-routeur hacké // LauchPad MSP430 et Stellaris // Panda II Arduino-like .NetMF sous VisualC#
RTFC: Read That F.....g Code / RTFD: Read That F.....g Doc / RTFDS: Read That F.....g DataSheet / RTFS: Read That F.....g Schematic / Wot da ya wanna D.I.Y. today ?

LibertyCareche

#23
Oct 06, 2012, 05:51 pm Last Edit: Oct 13, 2012, 10:00 am by LibertyCareche Reason: 1
non! mesuré à 52Ko au multimètre Fluke 185. 52000<>0 ! ( voir les 5 photos de la réparation jointes plus haut ) .

Par ailleurs je viens de trouver un post à ce sujet semble-t-il récurent :
http://arduino.cc/forum/index.php?topic=122947.0

Voici le schéma d'aptation en tension des entrées. Cela fonctionne malgré le seuil de tension des diodes . Des diodes Schottky sont  meilleures mais des 1N4148 suffisent (correction après avoir élucidé le problème : voir fin). Quand à la sortie, un CMOS intercalé suffit histoire le cas échéant de s'assurer de la transmission du signal MISO.
Quidquid agis, prudenter agas, et respice finem !

LibertyCareche

#24
Oct 07, 2012, 09:09 pm Last Edit: Oct 08, 2012, 01:15 am by LibertyCareche Reason: 1
Grande nouvelle... Je ne suis pas (encore) sénile  !!

J'ai essayé sur un Arduino Uno. Les premiers tests m'ont laissé penser que je devrai prendre une retraite anticipée ... mais finalement j'ai échangé la carte SD 64Mo encore une fois avec la 32Go et... miracle,... j'ai eu le "grand" bonheur de lire ceci :

Initializing SD card...Wiring is correct and a card is present.

Card type: SDHC
Could not find FAT16/FAT32 partition.
Make sure you've formatted the card




Après le premier problème d'ordre électronique, je me demande si :
1) le MEGA associé à une carte SD peut être un problème pour SD.h
2) une carte de 64Mo peut être un problème pour SD.h
3) une carte de dix ans d'âge qui fonctionne très bien (Je la teste une fois par heure) peut être un problème pour SD.h
4) contrairement à ce que l'on peut lire sur le site officiel, la FAT16 peut être un problème pour SD.h

voir réponse de fat16lib sur http://arduino.cc/forum/index.php/topic,125973.msg947984.html#msg947984


_ _ _ _ _ /_ _ _ _ _ /_ _ _ _ _ /_ _ _ _ _ Subsequemment , pourquoi SD.h ne peut trouver la FAT? _ _ _ _ _ /_ _ _ _ _ /_ _ _ _ _ /


Quidquid agis, prudenter agas, et respice finem !

Jean-François

Certaines cartes pas assez récentes ne sont pas reconnues, j'avais eu le même soucis, je n'y pensais plus  :smiley-mr-green:
MacBook intel core 2 duo  os X snow Leopard 10.6<br/> eMac PPc G4  os X Leopard 10.5<br/>powerbook G4 os X Leopard 10.5
imac PPC G3 os X Pa

LibertyCareche

Nouvelle encourageante s'il en est, mais puisque mon Intel i5 avec Windaube 7 arrive à l'exploiter (la carte SD de 64Mo) il est juste de supposer que SD.h n'est pas au point !?
Quidquid agis, prudenter agas, et respice finem !

Jean-François

Il vaut mieux utiliser une autre librairies, celle ci n'est pas "top" SDFat est mieux.
MacBook intel core 2 duo  os X snow Leopard 10.6<br/> eMac PPc G4  os X Leopard 10.5<br/>powerbook G4 os X Leopard 10.5
imac PPC G3 os X Pa

LibertyCareche

#28
Oct 09, 2012, 07:58 pm Last Edit: Oct 09, 2012, 10:02 pm by LibertyCareche Reason: 1
Cela tient-il de la malchance ?

Premier essai :
Carte SD 64Mo vieille de dix ans.
Arduino MEGA sous SD.h & CardInfo.
Lecteur de carte SD (LC studio) dont le pin de masse du régulateur 3,3V AMS1117 n'était pas connecté à la masse carte.
Résultat :
Négatif.

Deuxième essai :
Mêmes cartes mais erreur réparée (voir photo plus haut)
Résultat :
négatif.

Troisième essai :
Echange SD card pour 32Go
Mêmes cartes.
Résultat :
négatif.

Quatrième essai :
Mêmes cartes mais avec une adaptation en niveau 5V MEGA / 3,3V carte SD
(voir schéma adaptation niveaux)(avec 1N4148 au  lieu des BAT83 que je préconise).
Résultat :
négatif.

Cinquième essai :
Echange SD card pour 64Mo 10yo
Carte UNO...
Resultat :
négatif.

Sixième essai :
UNO sous SDFatLib & SDInfo.
Résultat :
négatif.

Septième essai :
Echange SD card pour 32Go
Résultat :
 Semi positif(signalement de codes erreur du programme).

Huitième essai :
Echange SD card pour nouvelle de 2Go.
Résultat :
 Semi positif(signalement de codes erreur du programme).

Neuvième essai :
échange des 1N4148 (voir schéma adaptation niveaux) pour des BAT83.
Résultat :
positif

Dixième essai :
Echange SD card pour 32Go.
Résultat :
positif

Onzième essai :
Echange SD card pour 64Mo.
Résultat :
négatif.

Douzième essai :

Uno sous SD.h  & CardInfo.
Résultat :
positif

Treizième essai :
MEGA sous SD.h  & CardInfo ou sous SDFatLib & SDInfo.
Résultat :
positif


Conclusions :


  • Les cartes qui existaient avant la finalisation du standard SD ne sont pas à privilégier.

  • Les cartes sont sensibles à la forme des signaux.

  • Certains lecteurs de carte "LC studio" ont un défaut masse.




Un grand merci à Jean-François et Fat16Lib.


Quidquid agis, prudenter agas, et respice finem !

Go Up