Pages: 1 [2] 3   Go Down
Author Topic: Can I use the ATMega8 on it's own?  (Read 4384 times)
0 Members and 1 Guest are viewing this topic.
0
Offline Offline
Newbie
*
Karma: 0
Posts: 12
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

No. I am only using one set of rails. The AVcc and GND are supplied from the same rail as vcc and gnd. No other connections on that side. Plus I tested current on every pin that should have current and we are good.
Logged

Forum Administrator
Cambridge, MA
Offline Offline
Faraday Member
*****
Karma: 12
Posts: 3538
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Sorry, I meant the two halves of the single + and - rails.  Often, there a break halfway along the rail, even though it doesn't look like it.  Is that not the case with your breadboard?  Or are you bridging the gap in a way I'm not seeing?
Logged

0
Offline Offline
Jr. Member
**
Karma: 0
Posts: 91
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I think so too. The (+) and (-) rails are usually broken in the middle in these kind of breadboards. The right half of your breadboard isn't connected to (+).
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 12
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

The rails are broken in the middle. The top rails are not being used at all. I am using the bottom rails to power the chip. The unregulated  + power comes in at the right side and is wired to the 5V Regulator. From the regulator the 5V + is wired to the bottom + rail. The bottom + rail is then wired to 10K Resistor  to pin 1 and pin2. Then to pin 7 and pin 20 (for avcc). For Negative - the rail is wired to the power source.  And to pin 8 and pin 22. Notice the power led I added on the left. It is lit. I'm sorry but grateful that you are taking so much time to help me. I am skeptical of the fuse settings. Has anyone successfully run the ATmega8 off the board?
Logged

Forum Administrator
Cambridge, MA
Offline Offline
Faraday Member
*****
Karma: 12
Posts: 3538
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Maybe you're right about the fuses.  Reviewing the data sheet, I see this: "The CKOPT Fuse should always be unpro-
grammed when using this clock option" though no explanation is given.  Try these fuses:

High fuse byte: 0xda (CKOPT fuse set to unprogrammed = 1)
Low fuse byte: 0xd4 (low four bits changed to internal 8 MHz clock)
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 12
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Nope. I tried that. Same result. It runs on the board but will not run  off the board with only the internal clock.  Any other suggestions.
thanks anyway.
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 49
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

My larger board has jumpers located where marked, connecting the right to the left.  Is this what mellis and brainfart were talking about?




ñ
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 12
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

This board does not need jumpers.  I added jumpers but no effect.  Look closely at the pic.  Follow the neg. Comes in on the right. If jumpers were needed the power LED would not light. My current probe shows power (v5) at pin 7 and - at pin 8.  
I'm still waiting for one person to claim they have been able to run the ATmega8 off the board running on the internal clock.  
Logged

Forum Administrator
Cambridge, MA
Offline Offline
Faraday Member
*****
Karma: 12
Posts: 3538
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Hmm...

I would leave the jumpers on the breadboard, if for no other reason than to get people to stop suggesting them.  And if there is a break halfway along the + and - rails, how does the +5 volts you're supplying to the left side of the + rail make it to the chip?

Also, I would leave the fuses at the second setting I suggested: High fuse byte: 0xda, and Low fuse byte: 0xd4.

Have you tried burning a program to the ATmega8, eliminating the bootloader?  There are instruction at: http://www.arduino.cc/en/Main/Programmer

Then we could determine if the problem is in running any program at all, or just with the bootloader.
« Last Edit: November 03, 2006, 12:59:46 pm by mellis » Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 12
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Yes. I have already eliminated the bootloader. The program runs on the board but not off the board.
Logged

Forum Administrator
Cambridge, MA
Offline Offline
Faraday Member
*****
Karma: 12
Posts: 3538
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

What program are you running?  What's it supposed to do?

What pins are the LEDs supposed to be on?
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 12
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I am running the leb_blink example program. I added one more led on pin 12. The leds alternate on and off.

int ledPin = 13;                 // LED connected to digital pin 13
int ledPin2 = 12;
void setup()
{
  pinMode(ledPin, OUTPUT);      // sets the digital pin as output
   pinMode(ledPin2, OUTPUT);
}

void loop()
{
  digitalWrite(ledPin, HIGH);   // sets the LED on
  digitalWrite(ledPin2, LOW);  
  delay(1000);                  // waits for a second
  digitalWrite(ledPin, LOW);    // sets the LED off
  digitalWrite(ledPin2, HIGH);  
  delay(1000);                  // waits for a second
}
Logged

Forum Administrator
Cambridge, MA
Offline Offline
Faraday Member
*****
Karma: 12
Posts: 3538
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

If you still have them wired as they are in the picture, your LEDs are on the wrong pins.  Pins 12 and 13 are on the other side of the ATmega8, see: http://www.arduino.cc/en/Main/PinMapping
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 12
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

 smiley-grin  S U C C E S S !  It works.  I'm sorry for my stupidity.  I figured the pin 13 was pin 13 on the ATmega8 not pin 19.  Now can get busy on my rocket altimeter.  
THANKS a Million !
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 13
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hey,

I'm also trying to use a 28 pin Atmega328p chip on its own but it's not working. I had previously connected only VCC, AVCC & AREF to 5V and the two GND's to ground but I've realized from the above discussion that I'll also need to connect a 16MHz clock to the chip. But I have a few questions:
1) To what pin do I connect the clock to? And does it have to be a 16Mhz crystal clock e.g. this or this?

Also as in neurascenic's circuit:
2) Do I have to connect the VCC and AVCC to GND with capicitors & is there a minimum/maximum capitance I need to use?
3) Do I need to connect Pins 1 & 2 (Reset & RXD) to 5V? (It seemed Reset was already about 5V only with the connections mentioned above).

Thanks, and like rotor said: "Sorry for the newbie questions."

Sadiq.
Logged

Pages: 1 [2] 3   Go Up
Jump to: