Go Down

Topic: Problem mit 200 mA-Beschränkung des Mega (Read 3 times) previous topic - next topic

michael--g

Quote
Die Relais brauchen wohl mehr als 5V*20mA, d.h. müssten auch über Transistoren,vermutlich mit 12V angesteuert werden. Details hängen von deiner Relais-Karte ab, aber deren Stromversorgung kommt sicher nicht aus dem 5V Pin.


Die 5V-Relais bediene ich über eine I2C-Expander-Karte - aber den Vin und GND der Relaiskarte, die ebenso bisher am Arduino hängen, müsste ich dann genauso über das externe/zusätzliche 5V-Netzteil laufen lassen, oder?

Grüße
Michael

michael--g


Quote
Die 4,7V bzw. 6V lege ich an die GND und Vin des LCD
???


Der LCD wird über I2C angesteuert, hat neben SDA und SCL eine eigne Versorgung, die bisher über den Mega läuft. Sobald ich aber diese per zusätzlichem Netzlauf laufen lasse, zeigt das LCD ncihts mehr an (außer, dass es leuchtet).

michael--g


... ein weiteres Problem dar: die ermittelten Werte schwanken enorm, im Bereich von 2-5 Grad Kelvin, dabei führe ich auf einen Schlag jeweils 300 Messungen, die ich mittle. Ich vermute, dass das mit zu wenig Power zusammenhängt.


Vielleicht weiß auch jemand das zu deuten: alle Fühler sind identisch (LM35DZ), angeschlossen sind sie an Pin8-13. Die gelieferten Werte schwanken aber in einer Breite von 2-5 Grad Kelvin - außer dem, der an PIN8 hängt, der bewegt sich um max 1/1024!

Rätsel über Rästsel :-?

Grüße
Michael

uwefed

Einiges zum klarstellen:
* Die 200mA sind der Gesamtstrom der über die Versorgungspannungspin Bzw Masse-Pin des ATmega2560 fließen dürfen. Das hat nichts mit dem Strom der auf 5V verbraucht wird zu tun
* eine 5V Schaltung mit 6V zu versorgen macht sie ziemlich sicher kaputt.

1. Besorg Dir ein ordentliches 5V Netzteil genug Strom liefert.

2. Die Spannungsmessung über die Analog-Eingänge funktioniert über eine Referenzspannung. Diese ist normalerweise die 5V Versorgungspannung. Wenn diese wegen zuviel Verbrauch schwankt hast Du Falschmessungen.
Wenn Du den LM35 verwendest kannst Du die interne 1,1V Referenz nehmen.

Grüße Uwe

michael--g

Hallo Uwe,

ich gehe mit.

* Die 200mA sind der Gesamtstrom der über die Versorgungspannungspin Bzw Masse-Pin des ATmega2560 fließen dürfen. Das hat nichts mit dem Strom der auf 5V verbraucht wird zu tun


Wenn ich diese 200 mA anzappfe, um mein LCD u.a. damit zu versorgen, welcher selbst 200 mA braucht, ist es schlecht, so weit bin ich auch. Daher brauche ich auch eine zusätzliche Stromquelle, so wie geschrieben.

Quote
* eine 5V Schaltung mit 6V zu versorgen macht sie ziemlich sicher kaputt.


Ist schon aus :-)

Quote
1. Besorg Dir ein ordentliches 5V Netzteil genug Strom liefert.


Scheint mir auch. Aber dass 4,7V für das $"§&-LCD nicht reichen, ist ein Ding.

Quote
2. Die Spannungsmessung über die Analog-Eingänge funktioniert über eine Referenzspannung. Diese ist normalerweise die 5V Versorgungspannung. Wenn diese wegen zuviel Verbrauch schwankt hast Du Falschmessungen. Wenn Du den LM35 verwendest kannst Du die interne 1,1V Referenz nehmen.


Mache ich bereits. Schwankungsbreite hat daher mit der 10b-Auflösung nichts zu tun.

Grüße
Michael

Go Up