Go Down

Topic: wireless proto shield. Digi XBEE WIFI - connection issues (Read 3 times) previous topic - next topic

PaulS

Quote
The manual only is for interfacing between the two XBEE's and is very basic to have them communicate with each other as a Adhoc network (or point to point.)

I don't know what manual you are talking about. The one I linked is clearly for the WiFi XBee and includes things you need to do to your wireless router in order for the WiFi XBee to connect to it.

caniff01

I have setup my module to attach to my Router by doing the instructions. However, It specifically addresses setting the 2 modules to communicate with each other on the DIGI XBIB-U-CAP Development boards Page 14 - 17 by giving the module IP addresses in each window (page 16).  This is great if you are doing a mesh point to point.  However, I want to use one module with a micro controller (Arduino UNO.)  which the manual does not address.  So I have programmed the wifi module as suggested in the manual except for setting the module destination ip.

Once I plug it into the Arduino wireless Proto shield I have the switch set to micro so that it communicates with the server program that has been uploaded into the UNO.  Next I power it on.  If I do a ping from any of my local computers It will ping correctly.  If I try to access the webpage that the server program creates then it gives me a page not found message. 

Thanks for Asking the questions i appreciate it!  Hopefully it will trigger something that will get me see what I am missing....

PaulS

Quote
If I try to access the webpage that the server program creates then it gives me a page not found message. 

What do you see on the serial monitor as you do this? What are you typing in a browser to try to access the web page?

caniff01

Interesting....  the web site in the browser says, "Internet Explorer can not display web page" and If I pull up the serial monitor in arduino program it says that the WIFI shield cannot be found...hmmm...

why would it not find the shield?

PaulS

Quote
why would it not find the shield?

You'll need to look at the library source code to answer that question.

It might be easier to help you if you'd actually post the output you get. Your choice.


Go Up