Pages: [1]   Go Down
Author Topic: Cannot upload to Arduino Leonardo  (Read 1643 times)
0 Members and 2 Guests are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 1
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I followed many troubleshooting, and installation tutorials with no success. I have tried running the ArduinoIDE on two computers 32bit and 64bit, as well as many different operating systems (Windows 7, Windows XP, Ubuntu 12.04, BackTrack5 R2). The problem is I cannot find the Leonardo on the specified port. My available ports are not available in Device Manager (Windows 7 x64), and therefore I cannot install the Arduino drivers. Any suggestions?
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 4
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I found that switching to a different USB cable got me past that point.  Odd, since the "bad" USB cable works fine with other devices.  I've read at least one other post where someone else experienced this.
My current problem is that my Leonardo now shows up as "Unknown Device" in Win 7 Device Manager, and no device driver update is allowed.  Seems to be a current problem with the Leonardo since I'm reading a lot about it on the forums.
Anyway, I hope it works for you to switch to a new USB cable.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 4
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Okay, just got mine working.  Not sure if this will work for anyone else, but I played with the sort-of-working USB cable, straightening and unstraightening it to change its electromagnetic geometry, and then I plugged and unplugged the connector at the Leonardo several times.  Finally, after the 3rd unplug/replug, my Win 7 laptop recognized it as a Leonardo and allowed me to upload a simple modified blink test sketch.  Works fine now!
Just for fun, I tried my original "bad" USB cable, and it still doesn't work.  Power is delivered to the Leonardo and it lights up just fine, but the PC doesn't recognize that it's been plugged in at all.
Seems like the Leonardo is very sensitive to having just the right USB cable.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 3
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Is there a better solution to this problem by now?
I am experiencing similar problems. After connecting
the Leonardo board via USB cable to the computer
(Ubuntu 12.04) the device is not recognized.

dmesg reports:

> [  814.060450] usb 2-1.6: new full-speed USB device number 81 using ehci_hcd
> [  814.467371] usb 2-1.6: device not accepting address 81, error -32
> [  814.467597] hub 2-1:1.0: unable to enumerate USB device on port 6

I tried several different cables as recommended but no success there. And different
computers (W7, Linux 10.04) but getting similar errors. Therefore I conclude that
the Arduino board seems to be the cause of the problem.

Any advice on howto proceed on this?

Thanks!
Logged

Pages: [1]   Go Up
Jump to: