Go Down

Topic: temperature sensors (Read 602 times) previous topic - next topic

pittom

Hi,i did not play with arduino for a while and now trying to do temperature sensor with  OneWire but every example does not work.My plan is to have 2 or 3 temperature sensor hooked up to hot tub to keep from freezing pump,check and set/turn on heat all from phone. I have got my uno and ethernet shield to work over internet but can not find OneWire code that workes so i can learn from.

does anyone have code that works?

thanks tom

PaulS

Quote
does anyone have code that works?

Yes, I have some. Probably won't work with your sensors. On the other hand, it might. If you said what kind of sensors (in the form of a link), and showed your code, and explained what "it didn't work" really meant, perhaps some real help would be forthcoming.

MarkT

Which temperature sensor?  What code?  We are not mind readers.  [well perhaps on a good day!]
[ I won't respond to messages, use the forum please ]

pittom

this is the sensor https://www.sparkfun.com/products/9438 and the arduino  library OneWire

dhenry

If you want to use OneWire on that sensor, it is probably a ggod idea that that sensor speaks OneWire.

MarkT

LM335A requires analogRead(), not OneWire.
If you really want some code for it you could look at that page and read the "Comments" section.
[ I won't respond to messages, use the forum please ]

pittom

well thanks anyway but i tried codes from "Comments" section and when i check code it comes up error and not sure why,that is why i asked if anyone had sample code that works so i can learn from

PaulS

Quote
but i tried codes from "Comments" section

Show us what code you tried. Don't expect us to go looking.

Quote
and when i check code it comes up error and not sure why

Perhaps you could ask somewhere. Like, maybe, I don't know, how about here on the forum? Post the error messages.

Go Up