Go Down

Topic: WeMos D1 -- UNO like wifi board based ESP-8266 (Read 9844 times) previous topic - next topic

wemos

Sep 06, 2015, 11:37 am Last Edit: Sep 06, 2015, 11:41 am by wemos
We made a wifi board, named D1

  • based on the ESP-8266EX.
  • Arduino Compatible, you can use it on Arduino IDE.
  • 11 Digital I/O pins
  • 1 Analog Input pin
  • OTA -- Wireless Upload(Program)
  • On board switching power supply -- Max 24V input, 5V 1A output






more: http://www.wemos.cc/d1

robtillaart

Sounds nice,

the silk is missing some analog pins and I2C
Rob Tillaart

Nederlandse sectie - http://arduino.cc/forum/index.php/board,77.0.html -
(Please do not PM for private consultancy)

Chagrin

the silk is missing some analog pins and I2C
One analog input is all that the ESP8266 has available.

Isaac96

How about an analog mux? (That would probably take too many digital pins, though)
Do not PM me for help.Only links to topics.
CONNECT THE GROUNDS!

After Tuesday, even the calendar goes W T F

Tagem

#4
Nov 13, 2015, 06:52 am Last Edit: Nov 13, 2015, 07:01 am by Tagem
Hi!,

I try to install the wemos d1 files in the arduino IDE, however it fails with a file not found from the wemos.cc website.. The website itself seems down.

Does any one know another json link to get support in the arduino IDE?

Thanks!!

Deshke

#5
Dec 25, 2015, 02:30 am Last Edit: Dec 27, 2015, 08:01 pm by Deshke
Hello, ive got me a Wemos D1 and installed the arduino IDE + driver etc (followed all instructions from Wemos website) but the D1 does not get recognized in the IDE under ports after connecting it with a micro USB.

I already searched the web but couldnt find anything helpfull.

Ive tried with Windows 10 and with a Mac os x (El capitan). Someone has any suggestion please?

Thank you in advance.


edit: fixed it. Don't use latest version of Arduino IDE, only works with version 1.6.5

msveden

Hi,

I have downgrade to IDE 1.6.5 but I still get the following messages:

warning: espcomm_sync failed
error: espcomm_open failed


My WeMos looks like the picture bellow with DIP switches and I think DIP 1 is suppose to be set to off when upload the code from IDE... But it doesn't matter how I put the switches. I still get the same error messages.


Please help me!

mpena

Hi folks!


Solution or El Captan: http://tzapu.com/making-ch340-ch341-serial-adapters-work-under-el-capitan-os-x/


See you!
Mauricio

bkenobi

I have a Wemos D1 on order and am curious about inturrupts.  I haven't found documentation suggesting that the EPS8266 does/does not support timers.  I have a project that I want to switch from an Uno with wired Ethernet shield to a D1 but it must support interrupts in order to properly receive RF (via RF69 module).

Gawan

Hi,

what about I2C ?
It basically works with ESP8266 (NodeMCU), but on WeMos it fails all the time (for me).

Does it work ?

BR
Gawan

Gawan


ganesamoorthy

Arduino 1.6.7...will it be support for ESP8266 ....How do install the driver for the same?

filip_amator

Hello,

D1mini works fine with Arduino 1.6.8 and drivers&examples from wemos.cc website. I installed additional packages according to the instructions here http://www.wemos.cc/tutorial/get_started_in_arduino.html
using easiest way (without git).

HelloServer from ESP8266WebServer compiles without any errors/warnings and D1mini nicely connects to the home wifi router.

Go Up
 


Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

Arduino
via Egeo 16
Torino, 10131
Italy