Go Down

Topic: Web4robot I2c compatibility issue (Read 4464 times) previous topic - next topic



I am running into a compatibility issue when I try and use the new LiquidCrystal(F. Malpartida) library.  What I mean by this is a screen filled with garbage.  I'm not sure what to do here it works fine with the supplied library but I know going forward it would be easier if I could use this library. 

I have modified the code for the correct I2c address all this does is change the garbage that is displayed.

I'm at a loss for what to do except use the library that works and start my project from scratch.



*Project is a Reef LED dimmer controller /w menu for manual control of dimming.


You haven't given us very much to work with.



I wasn't sure what you needed.

What do you need code? schematic? both more?

if it helps I'm using the library that works from the web4robot website.
the 2nd library that I'm having issues with is the one I obtained when I tried to test MENWIZ menu system.

I didn't modify the the library files and I am starting with the "Hello World" code.

At first I didn't change anything just upload/test garbage on screen.
Then I started changing code so that it looked like the "Hello World" from the Web4Robot one.  Still had garbage I tried disconnecting the RX/TX wires that resulted in a  blank screen no garbage(atleast it changed)

*Note the Web4Robot code works with these connected or disconnected.

Schematic I followed exactly.  I do have a 2nd I2c board but it works perfectly.

if you need more information let me know, and I will try to supply you with information.


In order to get the library going what you need is to initialize it correctly. To do so, you need to know how the LCD is connected to the I2C expansion module. That is, how is the actual LCD module wired to the module.
The connection to the I2C doesn't help because you can't see how it is connected (that is kind off the standard I2C connection). Once you have this, you will need to initialize the module accordingly. Please refer to the HW section of the library repository for an example.

If you are seeing garbage characters on the LCD, you have the correct LCD address but the initialization of the library is not correct.


The I2C board is soldered directly to the LCD with the use of a pin bus.  1 to 1, 2 to 2, etc...

I'll look into the initialization and see if I can figure it out.  One of the things I have noticed is that the Web4Robot sets the Col/Rows in a different spot then the New Liquid Crystal library.

Web4Robot Before Setup()
LCDI2Cw lcd(16, 2, i2cAddress);

In setup it only has: lcd.begin();

This might be what the issue is.  If it is I can't seem to get the new LC to duplicate that.


I think that some members of the forum have already sorted out how the backpack is wired to the LCD and have initialised it with the New LC lib. Do a search in the forum using the keywords for the module you have and New LiquidCrystal library.

I will try to find it but a bit busy right now and may take a day or two to get to it.



I searched the forums found nothing about web4robot and new liquid crystal.  Did fine web4robot and the Menwiz menu. 

I have updated that code to work for the web4robot so this is solved now on to other things which I don't even know how to do yet.



Cool! Great one.

Hope you enjoy the library.


Can anyone send me a copy of the LCD-FLEXEL.pdf and the C library of the Web4Robot LCD-FLEXEL board please?


Can anyone send me a copy of the LCD-FLEXEL.pdf and the C library of the Web4Robot LCD-FLEXEL board please?

You will probably have better luck if you start a new thread with an appropriate title instead of resurrecting an unrelated two-year old post.



Go Up