Go Down

Topic: Problemi con lettura numero di giri di una ventola PC e TIP132 (Read 2 times) previous topic - next topic

superzaffo

dopo una serata di prove, con il circuito con il TIP132 e del circuito con il TIP137, non sono riuscito a capire perchè non riesco a comandare l' accensione e lo spegnimeto di una ventola tramite il polo positivo.
Con il TIP132, se tolgo la resistenza da 600 la ventola si spegne, altrimenti resta sempre accesa. Anche se porto ad a low il pin di arduino.
Con il TIP137, anche qui la ventola resta sempre accesa, l' unico modo per fermarla è togliere la tensione nel collector.
Spero solo di non aver daneggiato i componenti.
Spero che qualcuno mi possa venire in aiuto.

Notte a tutti

cyberhs


superzaffo

Questo è lo schema che mi avevi dato.
In questo caso se inserisco la resistenza da 600 la ventola continua a girare.. se la tolgo si ferma ma non viene fatta partire dal' arduino.

superzaffo

Scusami... tanto per essere completo...
Con questo schema http://arduino.cc/forum/index.php/topic,13484.15.html invece la ventola continua a girare appena connetto i cavi al TIP137 ai capi C e E.
Non c'è modo da farla fermare...

Grazie per l' aiuto

cyberhs

Con lo schema che ho inviato la ventola funziona al contrario, cioé fornendo tensione al LED del fotoaccoppiatore la ventola si ferma e viceversa.

Ma non credo sia questo il problema.

Prova ad aumentare il valore del resistore ad 1k o più.

superzaffo

ok allora, provo portare la resistenza da 600 a 1k o 2k.
Domanda: volendo testare il circuito, come posso fare usando il tester ?

Per non aver dubbi, ho fatto un piccolo sketch che attiva il pin e lo disattiva ogni 5 sec.  :smiley-slim:

cyberhs

Puoi anche evitare di usare Arduino: se colleghi il resistore di ingresso direttamente ai 5V simuli quello che farebbe Arduino.

Collegandolo ai +5V la ventola dovrebbe fermarsi.

Domanda stupida, hai collegato anche la massa di Arduino, vero?

superzaffo

Certamente e sinceramente avevo anche provato a collegare a +5v, ma la ventola continua a girare :-)
E del secondo circuito che ti ho postato che mi dici ? Perchè se collego il + della ventola al pin E e i 12v al pin C del TIP137 la ventola continua a girare ? E se io (per fare una prova stupida) collegassi il pin B del TIP137 a GND, invece che al transistor ?
Cosa dovrebbe succedere ?

Grazie

cyberhs

Ho provato il circuito che ti ho mandato e sul mio simulatore funziona.

Quest'altro, invece, è un po' diverso e contempla sia un NPN che un PNP.

Non badare alle sigle: non avevo componenti simili.

I resistori da 30 ohm simulano un assorbimento di 350mA

superzaffo

Scusami.. simulatore ?
Comunque adesso faccio le prove e poi ti dico
Grazie

superzaffo

Sto provando...
All' uscita del pin 6 del 6n135 con l 5v attiva mi da -.003V con la 5V spenta nel pin 2 con R da 220 mi da 0.113V
Adesso con una resistenza di pull-up da 22k funziona.. anche se comunque (con la 5v attivata mi passa lo stesso 0.131V, e nel cavo giallo della ventola 0.131V)
Da tenere presente che comunque la Vin che ho non è stabilizata 12V ma arriva anche a 15-16.
Adesso proverò l' altro schema.. ti faccio sapere.
Grazie

superzaffo

Ho fatto diverse prove sugli schemi con il PNP, anche per aumentare un po' le mie conoscenze, e ti posso dire funzionano tutti.
Il problema era solamente nella resistenza di pull-up, che deve essere più grande (22K).
Inoltre mi hanno postato nel forum internazionale questo link che secondo me è molto utile per capire il funzionamento dei PNP
http://incredulist.blogspot.it/2012/10/high-side-switching.html
Grazie mille di tutto.

P.S. Mi devi spiegare cosa intendi per simulatore...  :D

cyberhs

Uso un simulatore per vedere come variano (in teoria) i circuiti che progetto.

E' di grande aiuto per evitare grossolani errori.

superzaffo

Interessante... non è che mi puoi dare qualche riferimento link ?

cyberhs

Quello che uso io è CircuitMaker2000, ma molti altri usano LTspice

Go Up