Pages: [1]   Go Down
Author Topic: Arduino probabilmente rotto per eccessiva corrente  (Read 211 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 2
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Salve, sono uno studente di un ITIS che insieme ad un compagno ha deciso di sviluppare un progetto per la nostra maturità tecnica. L'intenzione è quella di muovere un vecchio braccio meccanico trovato a scuola ( dell'87 ca.  smiley-eek-blue) composto da vari motori passo-passo. Ma non è questo il punto... Pochi giorni fa, durante una prova con il nostro Arduino collegato con USB, il computer si è improvvisamente spento. Dopo circa 5 minuti in cui sembrava completamente morto e non rispondeva al comando di accensione, il PC si è acceso, ma l'Arduino ed una tastiera collegata anch'essa tramite USB non funzionavano più: anzi, non venivano nemmeno riconosciute (l'Arduino resta con il LED "ON" e il 13L accesi ma senza funzionare). Da lì l'idea di aver bruciato la scheda di controllo delle porte USB... ma collegando altri dispositivi esse funzionano, quindi non è quello il problema.

Adesso spiego nei particolari quale fosse la "prova" , con uno schema:



Il circuito a sinistra è l'ENABLE: tramite quello, con un segnale HIGH dall'arduino decidiamo se attivare o disattivare l'alimentazione a 12 V dei motori. Era stato azionato con i 5V diretti dell'Arduino. I fili del motore (4) erano collegati ognuno ad un circuito come quello in basso a destra: sempre con un segnale HIGH dall'Arduino, decidevamo se far andare a GND la bobina o no, quindi attivandola o disattivandola. Questo procedimento era operato velocemente su tutti e quattro i fili del motore, in modo da simulare i passi. Quindi con un coccodrillo collegato al VIN di Arduino passavamo velocemente da una resistenza all'altra del circuito per i passi. (Tutto questo procedimento doveva funzionare con uno shift register gestito dal software di Arduino, ma durante questa prova era fatto tutto a mano)

PS: il GND dell'alimentatore era collegato con il GND dell'Arduino

L'unica ipotesi che ho è quella di aver "fatto uscire" troppa corrente dall'Arduino, di conseguenza bruciandolo e che poi in qualche modo sia andata a finire anche nella tastiera USB, rompendo anch'essa.

La domande sono: è possibile che sia andata così? C'è la possibilità di rimediare ai danni dell'arduino?
Spero che mi possiate aiutare
Logged

ITALY
Offline Offline
Full Member
***
Karma: 1
Posts: 188
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Ciao,
secondo me dovresti essere più specifico nella descrizione del problema. Arduino viene riconosciuto su una delle porte seriali? Riesci per esempio a caricare lo sketch di esempio "blink" su Arduino?
Oppure hai un problema sulle porte del micro?
Logged

Global Moderator
Italy
Offline Offline
Brattain Member
*****
Karma: 332
Posts: 22798
Logic is my way
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Le schede madri diciamo "di qualità" hanno una protezione che interviene a tagliare l'alimentazione sull'USB nel caso che ci sia un prelievo eccessivo di corrente. Può darsi che sia intervenuta questa protezione, che ti ha bloccato l'uso delle porte USB per qualche tempo.
Dopo l'anomalia, se però l'Arduino non viene più riconosciuto ma le altre periferiche sì, potrebbe darsi che si sia danneggiato. Però come dice DevonMiles dovresti descrivere meglio le anomalie che hai riscontrato. Ad esempio, dici che anche una tastiera USB non veniva più riconosciuta però non hai detto se, in un secondo tempo, è tornata a funzionare oppure no. Se ora funziona, la stai usando sulla stessa porta di prima? E che succede se la colleghi alla porta che stava usando l'Arduino? Potrebbe darsi che un corto o una sovracorrente abbia rovinato solo una porta USB (a me è capitato con un PC) per cui a quella porta non funziona più nulla correttamente.
Logged


Offline Offline
Newbie
*
Karma: 0
Posts: 2
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Scusate, ho dimenticato di specificare.
Per quanto riguarda la tastiera, appena la collego compare un bel pop-up "Dispositivo USB non riconosciuto", con il suggerimento di staccare e riprovare a collegarlo, ma ottengo lo stesso risultato. Non si accendono nemmeno i led della tastiera (ad esempio CapsLock Blocnum ecc.).
Riguardo all'Arduino, invece, non ottengo il pop-up nè il classico suono di dispositivo usb collegato (mentre con la tastiera sì), ovvero è come se non collegassi nulla; però sull'Arduino si accendono il led verde di "ON" e quello arancione del LED13.

Tutte le porte USB funzionano correttamente con qualunque altro dispositivo USB.
« Last Edit: April 29, 2014, 07:34:42 am by simope » Logged

Offline Offline
Full Member
***
Karma: 4
Posts: 211
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Prova a collegare tastiera e arduino ad un altro pc...
Potrebbe essere una sorta di prova del 9
Logged

Pages: [1]   Go Up
Jump to: