Pages: [1]   Go Down
Author Topic: WiFly problem  (Read 667 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 45
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Good day,

I have a problem compiling an example code on the Arduino 1.0 IDE from the Wifly example list.

When i compile it, it has this errors,

cannot declare variable 'client' to be of abstract type 'Client'

I'm using sparkfun's WiFly RN-131C shield. Is it a incompatible library problem or is it something i missed out on?

I will be modifying my code from a Ethernet enabled shield to a WiFly shield. trying to implement the basics which is the webclient sketch first.

Any help here would be appreciated!

Cheers,
Kenneth
Logged

Seattle, WA USA
Offline Offline
Brattain Member
*****
Karma: 614
Posts: 49386
Seattle, WA USA
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
When i compile it
It would be nice it you posted the code. And said what version of the IDE you are using.
Logged

Gosport, UK
Offline Offline
Faraday Member
**
Karma: 21
Posts: 3113
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
And said what version of the IDE you are using.

To be fair, he did.

Quote
on the Arduino 1.0 IDE
Logged

Seattle, WA USA
Offline Offline
Brattain Member
*****
Karma: 614
Posts: 49386
Seattle, WA USA
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
To be fair, he did.
So he did. Missed that. Sorry.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 45
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

to be honest, i have no idea what's wrong.

when i compile my program using the ethernet library,

Code:
#include <Ethernet.h>

the "Ethernet" will change orange

but now,

Code:
#include <WiFly.h>

doesn't change orange! any clues?

i've got the library from here:

https://github.com/sparkfun/WiFly-Shield
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 45
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

crap, sorry i should have googled it before posting it in here..

I've got a solution, the library i used wasn't compatible with my IDE version.

i've got a working library compatible with my version.

the link for the library for IDE 1.0 is:

https://github.com/jmr13031/WiFly-Shield

apologise for the mistake!

thanks guys! (dxw00d and PaulS)

Logged

Gosport, UK
Offline Offline
Faraday Member
**
Karma: 21
Posts: 3113
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
doesn't change orange! any clues?

I wouldn't worry too much about the colour coding. It relies on library writers providing files (called keywords.txt) with their libraries. Not everyone does.
Logged

Pages: [1]   Go Up
Jump to: