Go Down

Topic: I2C hangs (Read 15175 times) previous topic - next topic

kaor

I'm sure that this isn't due to bad soldering , anyway I'll check everything with many tests when I have time.
?????? ?????? ?????, ??? ??? - ??????????!

kaor

I run the same code with L3G4200D and everything goes ok.
?????? ?????? ?????, ??? ??? - ??????????!

wayneft

@kaor
There's another rev of the library that I just posted which seems to handle a majority of lockups now so you may want to try this one also. 
I2C GPS Shield

Checkout my Open Source GPS Tracker on Kickstarter

kaor

wayneft, ok, I'll try it asap.
?????? ?????? ?????, ??? ??? - ??????????!

Tentacle

#79
Nov 12, 2012, 04:41 pm Last Edit: Nov 12, 2012, 04:44 pm by Tentacle Reason: 1
Hi there,

I came across the same problem as you did. I tried a couple of things concering I²C conduction and prohibition. But nothing did the trick for me. Finally I used a shielded cable for the 3.3V and GND connection, which solved my problems. Since then I have not experienced any problems again. I hope it workes for you or anybody else with that problem too!

P.S.: I am sorry to bring up this old thread. But this thread was more or less the hint for the right solution, so I thought it would be nice to leave a note for anybody with the same problem

I'm using itg3200/adxl345 to detect tilting angle and i'm having the exact problem. Reading from just the two sensors was a stroll down the park but when i try to run a motor and reading the sensors together in one loop, it starts to hang. The hangs happen randomly sometimes immediately after i power on the arduino, sometimes it takes a while to trigger the freeze.

Tentacle

I figured out, that you cant turn the 5V Pull Ups on the Mega off. Since I use a Level Shifter all the problems are gone.


Mr.Tentacle

How do you used a shielded cable for the 3.3V and GND connection?
I can't understand about it.

Tentacle

Hi,
I used a cable like this: http://www.eltim.eu/data/articles/images/small/s_1532.jpg , used the shield wire as the ground and the inner cable as the + cable. But like I said before, it didn't help. We just did it because we used 1000 watt engines and wanted to make sure that induction isn't running everything. But the problem with the board was that the i2c uses 5 volt on the mega but the sensor works with 3.3 volt. Nevertheless good luck with your project.

Go Up