Pages: 1 [2]   Go Down
Author Topic: Relais Stört DS18B20 kommunikation?  (Read 2840 times)
0 Members and 1 Guest are viewing this topic.
Forum Moderator
BZ (I)
Offline Offline
Brattain Member
*****
Karma: 270
Posts: 21856
+39 349 2158303
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

ok, so ist es mir klarer.
Was mißt Du wenn Du beide 5V gegen Masse mißt?
Versuch mal die beiden 5V Spannungen mit dem Meßgerät im Wechselspannungsbereich zu messen (So mißt Du die Restwelligkeit).
Grüße Uwe
Logged

Offline Offline
Jr. Member
**
Karma: 0
Posts: 85
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Gegen Masse habe ich genau je 5V und 12V je +/- wenige digits
Restwelligkeit gegen 0V
Ich vermute die Differenz der beiden 5V zueinander durch den Regler vom Board
Ich hatte ja schon fast den Gedanken die beiden 5V zu verbinden ich denke aber das hätte geraucht

Kann ich mi dem AREF Eingang dem Board die "fremden" 5V beibringen?
Logged

Forum Moderator
BZ (I)
Offline Offline
Brattain Member
*****
Karma: 270
Posts: 21856
+39 349 2158303
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Verstehe ich jetzt nicht. Du sagtest zwischen den 5V am 5VPin des Arduino und den 5V des 5V Netzteils mißt Du 0,8V Gleichstrom aber beide Spannungen sind 5V.
Grüße Uwe
Logged

Offline Offline
Jr. Member
**
Karma: 0
Posts: 85
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

jupp so ist es

ich mach mal nen Schaltplan und trage die Voltmeter mit Werten ein

es ist jedenfalls so das das Display mit den 5V vom Arduino läuft aber mit den 5V des Netzteils nicht...

Logged

Forum Moderator
BZ (I)
Offline Offline
Brattain Member
*****
Karma: 270
Posts: 21856
+39 349 2158303
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Ja, ein Schaltplan ist hilfreich damit ich verstehe was Du hast. Vieleicht hilft auch ein Foto.
Grüße Uwe
Logged

Germany
Offline Offline
Edison Member
*
Karma: 48
Posts: 2338
Arduino rocks
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Die gemessenen 0,8V klingen irgendwie nach dem Spannungsabfall über einer Diode. Bist du dir sicher, dass die Massen der Netzteile direkt zusammengeschlossen sind?
Logged

Mein Arduino-Blog: http://www.sth77.de/ - letzte Einträge: Teensy 3.0 - Teensyduino unter Window 7 - Teensyduino unter Windows 8

Offline Offline
Jr. Member
**
Karma: 0
Posts: 85
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

so hier der Schaltplan der Netzteile, es ist natürlich noch mehr angeschlossen
das geht auch alles, nur das Display zeigt nach wenigen Minuten nur noch wilde Zeichen wenn es am 5V Netzteil angeschlossen ist, Schließe ich es wie auf dem Bild direkt am Arduino an dann läuft alles perfekt

* Arduino Display_Schaltplan.pdf (383.02 KB - downloaded 50 times.)
Logged

Forum Moderator
BZ (I)
Offline Offline
Brattain Member
*****
Karma: 270
Posts: 21856
+39 349 2158303
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Du darfst nicht die 5V und die 12V gleichzeitig am Arduino anschließen.
Wieso brauchst Du denn die 12V am Arduino? Laß sie weg.
Grüße Uwe
Logged

Offline Offline
Jr. Member
**
Karma: 0
Posts: 85
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hallo Uwe

die externen 12V werden für Motoren gebraucht die über Transistoren am Arduino angeschlossen sind

es ist am Arduino nur die 12V angeschlossen,

die externen 5V habe ich nachgerüstet weil die 5V des Arduino nicht für alle Verbraucher reichte, danach liefen dann alle Zusatzgeräte und der DS18B20 Bus mit 10 Sensoren dran und das Display fing mit dem Spinnen an weshalb ich es einfach mal wieder am Arduino Angeschlossen habe

ich dachte auch es sei besser den Arduino über 12V Vin zu betreiben statt 5V an Vin , die 12V mit 5A sind nur für ein paar Verbraucher, das 5V Netzteil hat 7A wäre also reichlich da

wie meinst Du das mit dem Weglassen?


Logged

Forum Moderator
BZ (I)
Offline Offline
Brattain Member
*****
Karma: 270
Posts: 21856
+39 349 2158303
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hallo Uwe
die externen 12V werden für Motoren gebraucht die über Transistoren am Arduino angeschlossen sind
Ok. Arduino muß deswegen aber nicht mir +12V versorgt werden; es reicht die Massen der 12V und des Arduino zu verbinden.


Quote from: joh371
es ist am Arduino nur die 12V angeschlossen,
Laut Deinem Schaltbild ist das Netzteil in http://arduino.cc/forum/index.php/topic,127035.msg968113.html#msg968113 an J1 mit 5V des Arduino verbunden. Ist das kein Netzteil?

Quote from: joh371
die externen 5V habe ich nachgerüstet weil die 5V des Arduino nicht für alle Verbraucher reichte, danach liefen dann alle Zusatzgeräte und der DS18B20 Bus mit 10 Sensoren dran und das Display fing mit dem Spinnen an weshalb ich es einfach mal wieder am Arduino Angeschlossen habe
Hat das Display Hintergrungbeleuchtung?


Quote from: joh371
ich dachte auch es sei besser den Arduino über 12V Vin zu betreiben statt 5V an Vin , die 12V mit 5A sind nur für ein paar Verbraucher, das 5V Netzteil hat 7A wäre also reichlich da.
wie meinst Du das mit dem Weglassen?
5V an Vin ist eine schlechte Idee. Wennschon 5V an das 5V Pin.

Grüße Uwe
Logged

Offline Offline
Jr. Member
**
Karma: 0
Posts: 85
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hallo Uwe

vielen Dank für Deine Hilfe

also J1 ist kein Netzteil ist nur der 5V Ausgang des Arduino

Ja das Display hat eine Hintergrundbeleuchtung

Ich werde mal Umbauen und die 12 V nur für die Verbruacher nehemen und den Ardu direkt mit den 5V Verbinden
und Berichten

Vielen Dank für Deine Hilfe
Grüße Jörg
Logged

Offline Offline
Jr. Member
**
Karma: 0
Posts: 85
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

So hab nun alles Umgeklemmt die 12V Versorgen nur noch die Lambda Sonde und Motoren

die 5V Versorgen die Transitortreiber ,Relais und das Display (mit der Hintergrundbeleuchtung)

Spannungsverschiebungen sind weg

Danke an alle

(PS zur Erklärung warum ds vorher so komisch angeschlossen war: Es gab nur das 12V Netzteil und die 5V aus dem Arduino, hier hat der Strom des Arduino nicht gereicht und der Bus der DS18B20 ist zusammengebrochen. Darauf hin wurde das 5V Netzteil nachgerüstet aber der Arduino hat seine 12V behalten. Klingt komisch iss aber so)
Logged

Forum Moderator
BZ (I)
Offline Offline
Brattain Member
*****
Karma: 270
Posts: 21856
+39 349 2158303
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Schön daß wir Dir helfen konnten.
Grüße Uwe
Logged

Offline Offline
Jr. Member
**
Karma: 0
Posts: 85
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

also abschließend es läuft jetzt seit 3 Tagen völlig Störungsfrei

Danke nochmal an alle
Logged

Pages: 1 [2]   Go Up
Jump to: