Pages: [1] 2   Go Down
Author Topic: Logic level mosfets do not turn on, unless I touch them!  (Read 2016 times)
0 Members and 1 Guest are viewing this topic.
Pennsylvania
Offline Offline
Newbie
*
Karma: 0
Posts: 42
"There is no try. There is only do, and do not."
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Following the example by lady ada here: http://www.ladyada.net/products/rgbledstrip/
Using the STP16NF06 as suggested, wired properly, with a TLC 5940 driving them commanded by an arduino, nothing happens unless I hold the PCB in my hands. simply touching the pins of the mosfets, while a fade is running, turns them on until the fade completes (I can let go as soon as everything lights up). The RGB LED's stay dark until I touch the mosfets with dry, bare hands again. NOTE, I did not install the 10k resistors (yet) that I have seen in other depictions, but aren't those to make the mosfets turn back off? My current limiting resistor (IREF) on the TLC5940 is a 2.2k.
Logged

Anaheim CA.
Offline Offline
Faraday Member
**
Karma: 46
Posts: 2865
...
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

If a part is called for in a diagram, choosing to leave it out and expect normal operation would mean to me... that you know more than the person who designed it.
Asking why it doesn't work properly means that you don't understand at all. The parts, all of them, have a purpose and it isn't just to make things complicated.
Submitting a question here without a diagram and pictures and the sketch you are using is going to get you as much information as you have given and referring to a Link for a nonexistent part and circuit makes your whole request rather difficult. There are no 10K resistors, TLC5490's or anything else similar except the mosfets in the drawing. The Mosfet's should have a pull down on the gate to ground and 10K is a good value to use... although they aren't in the LadyAda drawing or even mentioned for that matter. What I think is that you don't have your board wired as the drawing shows. LadyAda, Limor Fried is very careful to test everything in a "Tutorial". That's how she really makes money...  By selling things that work... Every time, and can be successfully constructed by anyone...

{Edited for "Attitude and content". RKJ}

Bob
« Last Edit: October 14, 2012, 11:10:11 am by Docedison » Logged

--> WA7EMS <--
“The solution of every problem is another problem.” -Johann Wolfgang von Goethe
I do answer technical questions PM'd to me with whatever is in my clipboard

Pennsylvania
Offline Offline
Newbie
*
Karma: 0
Posts: 42
"There is no try. There is only do, and do not."
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

It is wired correctly or wouldn't do anything at all. I'm sorry I did not include drawing. Its the same as the  drawing except a micro controller triggers the TLC instead of the mosfets them selves. My thoughts, is the value of the TLC's IREF resistor possibly holding its output voltage too low to turn the mosfets on.

{Edited for "Attitude and content". DPM}
« Last Edit: October 15, 2012, 08:56:44 am by dpmattox » Logged

Anaheim CA.
Offline Offline
Faraday Member
**
Karma: 46
Posts: 2865
...
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

What TLC's? you showed a picture of an Uno and then proceeded to describe a totally different circuit... . . I did answer your question about the 10K resistors even though they aren't referenced anywhere except your rather vague question, vague because you didn't mention where or why... only a reference to "Other Depictions" unfortunately you didn't include that information. Submitting a question here without a diagram and pictures and the sketch you are using is going to get you as much information as you have given and referring to a Link for a nonexistent part and circuit makes your whole request all that much more difficult to answer. If it was wired properly and the sketch was properly written and tested..  It should work properly, that it doesn't indicates an error either in the sketch or the connected circuitry and since you report that the sketch works if you "handle" the circuitry, that information would indicate that the circuitry and not the sketch is at fault...

{Edited for "Attitude and content". RKJ}

Bob
« Last Edit: October 14, 2012, 11:06:28 am by Docedison » Logged

--> WA7EMS <--
“The solution of every problem is another problem.” -Johann Wolfgang von Goethe
I do answer technical questions PM'd to me with whatever is in my clipboard

Global Moderator
Offline Offline
Brattain Member
*****
Karma: 474
Posts: 18696
Lua rocks!
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Both of you calm down or I'll lock this thread.

- moderator
Logged

Anaheim CA.
Offline Offline
Faraday Member
**
Karma: 46
Posts: 2865
...
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Nick You are right and I apologise to the poster and to any and all offended by my yelling. I AM grumpy, I'm catching a cold and I didn't realize that I was so far over the top... I'm Sorry for my very questionable conduct as I am old enough to know better... I thought.

{Edited for "Attitude and content". RKJ}

Bob
« Last Edit: October 14, 2012, 11:14:00 am by Docedison » Logged

--> WA7EMS <--
“The solution of every problem is another problem.” -Johann Wolfgang von Goethe
I do answer technical questions PM'd to me with whatever is in my clipboard

Manchester (England England)
Offline Offline
Brattain Member
*****
Karma: 602
Posts: 33362
Solder is electric glue
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

So for the OP.
This sounds like the grounds are not connected.
Logged

Anaheim CA.
Offline Offline
Faraday Member
**
Karma: 46
Posts: 2865
...
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

The answer to the current limiting resistor question is not likely but still irrelevant without a drawing. Grumpy Mikes suggestion is more that likely the real answer to your issues but this is a guess as there is not enough information to do more than guess with.

Bob
Logged

--> WA7EMS <--
“The solution of every problem is another problem.” -Johann Wolfgang von Goethe
I do answer technical questions PM'd to me with whatever is in my clipboard

Offline Offline
Edison Member
*
Karma: 116
Posts: 2205
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

You may want to check that those mosfets are working indeed. Connect their gates to a power source and that will turn on the leds hard.

Once you have proved that, you can focus on wiring / coding.
Logged

Anaheim CA.
Offline Offline
Faraday Member
**
Karma: 46
Posts: 2865
...
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
Following the example by lady ada here: http://www.ladyada.net/products/rgbledstrip/
Using the STP16NF06 as suggested, wired properly, with a TLC 5940 driving them commanded by an arduino, nothing happens unless I hold the PCB in my hands. simply touching the pins of the mosfets, while a fade is running, turns them on until the fade completes (I can let go as soon as everything lights up). The RGB LED's stay dark until I touch the mosfets with dry, bare hands again. NOTE, I did not install the 10k resistors (yet) that I have seen in other depictions, but aren't those to make the mosfets turn back off? My current limiting resistor (IREF) on the TLC5940 is a 2.2k.
I think he did the equivalent, at least he acknowledges that the LED's turn on via the Mosfet's. I think the issue here isn't turning on the mosfet's but what is turning the mosfets on. I also think that without an accurate drawing there is little possible here except conjecture. The interesting point is this
Quote
(I can let go as soon as everything lights up)
as it indicates that most of his wiring is ok as it works... sort of and I wonder if the TLC5490 is wired properly as it is the component we know the least about from his sketch/schematic. {Edit: I do think that Grumpy Mike hit the issue dead on as it does sound like an open ground between the Arduino and the TLC5490's.}

Bob
« Last Edit: October 14, 2012, 11:17:43 am by Docedison » Logged

--> WA7EMS <--
“The solution of every problem is another problem.” -Johann Wolfgang von Goethe
I do answer technical questions PM'd to me with whatever is in my clipboard

Manchester (England England)
Offline Offline
Brattain Member
*****
Karma: 602
Posts: 33362
Solder is electric glue
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

The other thing is that the TLC5940 just pulls down so you need a pull up to 5V or more to drive the FETs.

If only you would show a schematic of what you actually have rather than a half baked mish mash of bits of circuits then we could definitively help.
« Last Edit: October 14, 2012, 11:55:18 am by Grumpy_Mike » Logged

Offline Offline
Edison Member
*
Karma: 5
Posts: 1730
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Instead of showing the circuit you followed, make your own shematic from what you actually did, sometimes just in doig that you can realize something you overlooked
Logged

Pennsylvania
Offline Offline
Newbie
*
Karma: 0
Posts: 42
"There is no try. There is only do, and do not."
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Sorry guys, church yesterday. I have attached an early, but applicable, schematic. I am also seeing differing of opinion on whether I should pull up or pull down the gates. As I said, the pulldowns in the schematic have not been soldered on yet. Holding the board in my hand, everything works as it should. Setting it down, nothing. Specifically, touching the Mosfet pins on the bottom of the board illuminates that channel in accordance with the running program. I am seriously considering dropping the TLC5940 in the next revision for ShiftPWM. But still need to figure out what's going on with the mosfets. If you guys are sure the IREF resistor on the TLC is not to blame, I will leave it alone for now.


* 551096_10151041106177730_293071566_n.jpg (63.27 KB, 737x960 - viewed 48 times.)
Logged

Manchester (England England)
Offline Offline
Brattain Member
*****
Karma: 602
Posts: 33362
Solder is electric glue
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

So what part of this did you not understand?

The other thing is that the TLC5940 just pulls down so you need a pull up to 5V or more to drive the FETs.
Logged

Pennsylvania
Offline Offline
Newbie
*
Karma: 0
Posts: 42
"There is no try. There is only do, and do not."
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

That part!
Logged

Pages: [1] 2   Go Up
Jump to: