Go Down

Topic: Programming an ATtiny85 with Arduino Code and Arduino Uno as Programmer (Read 4 times) previous topic - next topic

Coding Badly


The blue wire does not look correct.

Going from left-to-right, the second green wire is not necessary.

Tom Carpenter



The blue wire does not look correct.


In that diagram the black wire above the blue wire should be one hole to the left - I think the blue is correct.
~Tom~

marian42

Okay so I got it to work!

But I promise all I changed was attaching the three LEDs.
During the process the error led lights up shortly.
The power led stays on and the working led blinks.

The pullup resistor is not necesary.

Thanks for your help guys!

I tried it with another (small) ATtiny85 on a PCB with components attached and got this problem:

Code: [Select]

avrdude: stk500_program_enable(): protocol error, expect=0x14, resp=0x50
avrdude: initialization failed, rc=-1
         Double check connections and try again, or use -F to override
         this check.

avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51


and after some tries its always this one
Code: [Select]

avrdude: stk500_getsync(): not in sync: resp=0x00


During the upload only the power led is on.
This ATtiny already has a sketch on it.

Coding Badly

Quote
I tried it with another (small) ATtiny85 on a PCB with components attached and got this problem:


Components?

marian42

Two LEDs, a light sensor, a piezo buzzer and a button. It also has a battery slot and some resistors.
I dont have the schematics but I think the components are simply wired up to the five pins.

Go Up