Go Down

Topic: servo impazzito (Read 542 times) previous topic - next topic

bit95

ciao a tutti.

sto facendo girare un servo in base alla posizione di un potenziometro, ma ho un piccolo problema, infatti il servo trema tantissimo, e per evitare che tremi devo muovere il potenziomentro velocemente..........

possibile il potenziometro rovinato??eppure controllando con un tester sembra a posto

è veramente frustrante, avete qualche idea??

grazie

ciao

bit95

ok sono un idiota

avevo scritto questo nella conversione 10 bit/8bit.

gradi=map(posizione,0,1023,0,[font=Verdana]1179[/font]);

ho scritto 1179 invece di 179

scusate

ciao

Michele Menniti

eh come sei severo con te stesso, un errore capita a tutti, qui c'è gente che fa esplodere gli Arduini come se fossero fuochi d'artificio ;)
eppoi il problema te lo sei risolto da solo, no? Tanto id non devi essere :)
Guida alla programmazione ISP e seriale dei micro ATMEL (Caricare bootloader e sketch):
http://www.michelemenniti.it/Arduino_burn_bootloader.php
Guida alla Programmazione ATmega328 noP:
http://www.michelemenniti.it/atmega328nop.html
Articoli su Elettronica In:
http://www.michelemenniti.it/elettronica_in.html

cece99


eh come sei severo con te stesso, un errore capita a tutti, qui c'è gente che fa esplodere gli Arduini come se fossero fuochi d'artificio ;)
eppoi il problema te lo sei risolto da solo, no? Tanto id non devi essere :)

Pum pum booooom, gli atmega non fanno un bel botto, meglio gli ic di potenza o i led, sai che bei pezzi di plastica sparano in giro  :smiley-mr-green: :smiley-sad-blue:
Il Vero Programmatore non ha bisogno di manuali sull'assembler, sono
  sufficienti i data sheet dei microprocessori.

Subsea

dopo aver bucato, e per bucato dico proprio che ci vedevo da una parte all'altra di un uln 2004 e aver fatto una fissione con un led RGB penso il tuo errore sia niente! :smiley-mr-green:

Go Up