Go Down

Topic: [Risolto] Asynclabs WiShield 2.0 che si connette solo quando ne ha voglia (Read 940 times) previous topic - next topic

Skateman

Ma vi pare mai possibile? Ho una Asynclabs WiShield 2.0, la installo sul mio bel arduino, preparo il mio "bellissimo" sketch, e poi?? Si connette quando vuole lei!!! Nel senso...stesso router, stessa distanza dal router e stesso sketch, ma a volte si connette e altre no, provato anche su un altro router, qualcuno ha sperimentato lo stesso problema?  :smiley-eek-blue:

N.B.: Sto utilizzando le librerie a contributo degli utenti della asynclabs per utilizzare le funzionalità di DHCP e riconnettermi se cade la linea.

Potrebbe essere la qualità del modulo? me ne sapreste consigliare uno migliore eventualmente? in particolare sarei interessato anche a poter aggiungere una antenna esterna, perchè lo dovrei applicare un pò distante dal router!

uwefed

Ma con un PC funziona bene il collegamento wireless?
I Tuoi vicini usano anche loro il wireless e disturbano la Tua rete?
Ciao Uwe

Michele Menniti

Riesci in qualche modo a far partire Arduino e poi a dare un reset al solo shield e vedere se così si collega sempre?
Guida alla programmazione ISP e seriale dei micro ATMEL (Caricare bootloader e sketch):
http://www.michelemenniti.it/Arduino_burn_bootloader.php
Guida alla Programmazione ATmega328 noP:
http://www.michelemenniti.it/atmega328nop.html
Articoli su Elettronica In:
http://www.michelemenniti.it/elettronica_in.html

Skateman

Quote
Ma con un PC funziona bene il collegamento wireless?

Si 5 tacche su 5, mai avuto problemi con il pc
Quote
I Tuoi vicini usano anche loro il wireless e disturbano la Tua rete?

Probabilmente si, ma ho provato anche con un altro router, in un altra casa, in un altra zona...sarebbe pazzesco se il problema si rivelasse questo :smiley-surprise:
Quote
Riesci in qualche modo a far partire Arduino e poi a dare un reset al solo shield e vedere se così si collega sempre?

No quando resetto, si resetta tutto, resetto sia dal pulsante su arduino che da quello sulla scheda e anche da softwar

PS: Poco fa si connetteva, ora di nuovo non ne vuole sapere per quanti reset e ricaricamenti dello Sketch stia facendo :smiley-surprise:
PPS: Sto provando in questo momento anche a collegarmi con il telefono in modalità Thetering, senza protezione, con il telefono a 5 Cm dall'arduino senza risultati!

Un altra cosa strana e che per connettersi ci metta, nei momenti in cui ci riesce circa 40 secondi

Voi avete questa stessa scheda?

Michele Menniti

NO, ma recentemente qualcuno con un problema di uno shield che andava a momenti ha risolto ritardando l'avvio dello shield di qualche istante rispetto ad Arduino, ecco perché ti chiedevo di resettare il solo shield
Guida alla programmazione ISP e seriale dei micro ATMEL (Caricare bootloader e sketch):
http://www.michelemenniti.it/Arduino_burn_bootloader.php
Guida alla Programmazione ATmega328 noP:
http://www.michelemenniti.it/atmega328nop.html
Articoli su Elettronica In:
http://www.michelemenniti.it/elettronica_in.html

Skateman


Michele Menniti

Lo si può fare solo se lo shield ha un proprio pulsante di reset, quindi già premendolo dopo l'avvio di Arduino dovrebbe funzionare, altrimenti è inutile.
Guida alla programmazione ISP e seriale dei micro ATMEL (Caricare bootloader e sketch):
http://www.michelemenniti.it/Arduino_burn_bootloader.php
Guida alla Programmazione ATmega328 noP:
http://www.michelemenniti.it/atmega328nop.html
Articoli su Elettronica In:
http://www.michelemenniti.it/elettronica_in.html

Skateman


Michele Menniti

quindi è in parallelo al RESET di Arduino, evidentemente non può essere questa la soluzione; esiste un sito di questa scheda, magari delle FAQ?
Guida alla programmazione ISP e seriale dei micro ATMEL (Caricare bootloader e sketch):
http://www.michelemenniti.it/Arduino_burn_bootloader.php
Guida alla Programmazione ATmega328 noP:
http://www.michelemenniti.it/atmega328nop.html
Articoli su Elettronica In:
http://www.michelemenniti.it/elettronica_in.html

Skateman

Si, sto postando anche sul forum della asynclabs, intanto vorrei capire come si stanno trovando altri utenti che hanno la stessa shield perchè comincio a sospettare che sia difettosa a questo punto

Michele Menniti

Guida alla programmazione ISP e seriale dei micro ATMEL (Caricare bootloader e sketch):
http://www.michelemenniti.it/Arduino_burn_bootloader.php
Guida alla Programmazione ATmega328 noP:
http://www.michelemenniti.it/atmega328nop.html
Articoli su Elettronica In:
http://www.michelemenniti.it/elettronica_in.html

Skateman

Forse ho risolto, pare che il problema fosse un metodo aggiunto nella libreria a contributo degli utenti, il metodo era "async_init", utilizzando il metodo normale ossia "init" pare non dare più problemi!

Go Up
 

Quick Reply

With Quick-Reply you can write a post when viewing a topic without loading a new page. You can still use bulletin board code and smileys as you would in a normal post.

Warning: this topic has not been posted in for at least 120 days.
Unless you're sure you want to reply, please consider starting a new topic.

Note: this post will not display until it's been approved by a moderator.
Name:
Email:

shortcuts: alt+s submit/post or alt+p preview