Go Down

Topic: Old and Newly Purchased Mega Constantly Timing Out! (Read 466 times) previous topic - next topic

opkach

So last night I was trying to upload a sketch to my Arduino Mega and everything was lined up correctly. All the pins were in the right positions, the right board was selected and the right serial port is selected. I try to upload the sketch and I keep getting the message.

avrdude: stk500v2_ReceiveMessage(): timeout

I was rather annoyed and I need my mega for a presentation soon. I went to the store and ended up purchasing another Mega. I come home and the same thing is happening, it keeps timing out when I try to upload a sketch. I have tried multiple USB cables, multiple connections, tried with it bare (no connections).

What is the problem here?! Its really getting on my nerves and there are no !!! in my sketch either, which I had read previously may be the culprit.

Any ideas?
- opkach

Louis Davis

Maybe this is the issue your are seeing:
http://code.google.com/p/arduino/issues/detail?id=806

The suggested fix is to edit boards.txt and change the following line:
mega2560.upload.protocol=wiring

opkach

Thanks for the reply and this seemingly has worked! Awesome!

Appreciated  :D :D :D
- opkach

Go Up