Go Down

Topic: What about the bootloader? (Read 9285 times) previous topic - next topic


newhobby

I tried uploading using TX0/RX0, but wasn't able to.
What needs to be done for this to work?
Here is what I did:
1. Press Erase button
2. Press Reset button
3. On Arduino IDE 1.5.2, I click upload.
This is what I get:
Quote

Binary sketch size: 9,860 bytes (of a 524,288 byte maximum) - 1% used
Forcing reset using 1200bps open/close on port COM3
PORTS {COM3, COM9, COM35, COM39, COM40, COM47, } / {COM3, COM9, COM35, COM39, COM40, COM47, } => {}
PORTS {COM3, COM9, COM35, COM39, COM40, COM47, } / {COM3, COM9, COM35, COM39, COM40, COM47, } => {}
PORTS {COM3, COM9, COM35, COM39, COM40, COM47, } / {COM3, COM9, COM35, COM39, COM40, COM47, } => {}
PORTS {COM3, COM9, COM35, COM39, COM40, COM47, } / {COM3, COM9, COM35, COM39, COM40, COM47, } => {}
PORTS {COM3, COM9, COM35, COM39, COM40, COM47, } / {COM3, COM9, COM35, COM39, COM40, COM47, } => {}
PORTS {COM3, COM9, COM35, COM39, COM40, COM47, } / {COM3, COM9, COM35, COM39, COM40, COM47, } => {}
PORTS {COM3, COM9, COM35, COM39, COM40, COM47, } / {COM3, COM9, COM35, COM39, COM40, COM47, } => {}
PORTS {COM3, COM9, COM35, COM39, COM40, COM47, } / {COM3, COM9, COM35, COM39, COM40, COM47, } => {}
PORTS {COM3, COM9, COM35, COM39, COM40, COM47, } / {COM3, COM9, COM35, COM39, COM40, COM47, } => {}
PORTS {COM3, COM9, COM35, COM39, COM40, COM47, } / {COM3, COM9, COM35, COM39, COM40, COM47, } => {}
PORTS {COM3, COM9, COM35, COM39, COM40, COM47, } / {COM3, COM9, COM35, COM39, COM40, COM47, } => {}
PORTS {COM3, COM9, COM35, COM39, COM40, COM47, } / {COM3, COM9, COM35, COM39, COM40, COM47, } => {}
PORTS {COM3, COM9, COM35, COM39, COM40, COM47, } / {COM3, COM9, COM35, COM39, COM40, COM47, } => {}
PORTS {COM3, COM9, COM35, COM39, COM40, COM47, } / {COM3, COM9, COM35, COM39, COM40, COM47, } => {}
PORTS {COM3, COM9, COM35, COM39, COM40, COM47, } / {COM3, COM9, COM35, COM39, COM40, COM47, } => {}
PORTS {COM3, COM9, COM35, COM39, COM40, COM47, } / {COM3, COM9, COM35, COM39, COM40, COM47, } => {}
PORTS {COM3, COM9, COM35, COM39, COM40, COM47, } / {COM3, COM9, COM35, COM39, COM40, COM47, } => {}
PORTS {COM3, COM9, COM35, COM39, COM40, COM47, } / {COM3, COM9, COM35, COM39, COM40, COM47, } => {}
PORTS {COM3, COM9, COM35, COM39, COM40, COM47, } / {COM3, COM9, COM35, COM39, COM40, COM47, } => {}
PORTS {COM3, COM9, COM35, COM39, COM40, COM47, } / {COM3, COM9, COM35, COM39, COM40, COM47, } => {}
Uploading using selected port: COM3
D:\Software\arduino-1.5.2/hardware/tools/bossac.exe --port=COM3 -U true -e -w -v -b C:\Users\Owner\AppData\Local\Temp\build7113222333597006268.tmp/Blink.cpp.bin -R
No device found on COM3

newhobby

Well, nevermind.
I was able to use bossa command line tool just fine.
Then I went back to Arduino IDE and was able to upload too. So, maybe it was just bad connection in one of the jumper wires when I was trying before.


aureliusss

so where do i find the bootloader for ATMGEGA 16U2 in order to reproduce the exact function it does onto the Artduino DUE? i mean to load code from arduino IDE to SAM3X.

Go Up