Pages: [1]   Go Down
Author Topic: Problema avrdude: stk500_getsync():  (Read 838 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 6
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hola a todos, hace tiempo que vengo leyendo este foro y gracias a el me animé a comprar una Duemilanove. Una vez mas voy a intentar abusar de vuestros conocimientos.

Hacía tiempo que no tocaba la placa y cuando he retomado para continuar con un proyecto que tengo entre manos, me he encontrado con un problema al intentar cargar el sketch:

avrdude: stk500_getsync(): not in sync: resp=0x00

He buscado todas las soluciones posibles, pero me he quedado sin recursos. Solo me queda tocar el bootloader, cosa que no he hecho nunca y para la que creo que necesito hardware adicional.

Utilizo la versión de Arduino 1.0.1 y WIN7.

Espero que alguien me pueda ayudar.

Muchas gracias.
Logged

Offline Offline
Full Member
***
Karma: 0
Posts: 164
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Tienes bien configurada la placa en la lista de dispositivos?
El puerto es el correcto?
Has probado con otro còdigo de ejemplo a ver si ese se carga de forma correcta?
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 6
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Si, creo que todo lo obvio (por decirlo de alguna manera) lo he probado.

He pedido un Atmega 328 por Ebay con el bootloader ya cargado. A ver si hay suerte.
Logged

Donostia
Offline Offline
God Member
*****
Karma: 0
Posts: 740
elektronikadonbosco
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

La otra es que se haya roto el micro que controla la comunicación serie. Yo tengo uno con ese error, no he probado a reinstalar el bootloader porque creo que es cosa del otro micro, pero haber si lo pruebo. Salu2
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 6
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Finalmente he conseguido programar la placa (Duemilanove).

He tenido que reinstalar los drivers de la versión 023 de Arduino y no puedo programar desde la versión 1.0.1. Supongo que los drivers para programar desde la versión 1.0.1 son distintos a los de la 023 pero yo no logro instalarlos. De hecho no encuentro el driver adecuado.

Es posible programar con la Duemilanove desde Arduino 1.0.1?

Otra pregunta. compré un micro ATMEGA328 con el bootloader para la Arduino UNO precargado y no me funciona en la Duemilanove. Es posible que se necesite un  bootloader distinto para cada placa.

Gracias a todos.

EDITO. He desinstalado los drivers anteriores y he conseguido instalar los que vienen con la versión 1.0.1. Pero sigue el problema, puedo programar desde la 023 pero no desde la 1.0.1. Los puertos y la placa están bien selecionados.
« Last Edit: October 30, 2012, 05:54:24 pm by galotrofico » Logged

Pages: [1]   Go Up
Jump to: