Go Down

Topic: need quick help for an exhibition !!!! (Read 337 times) previous topic - next topic


hey guys!

i'm absolutely down and out.

i've got an exhibition next tuesday and i need to get my stepper working (i'm new to it). so it would be a pleasure, if u you could help me!

here's my problem:
although i've looked in the www for help, i'm not able to plug the stepper wires right into the motor shield (ladyada). i've tried to connect the wires with the sections M1 and M2, but nothing happened.
then i've removed the power jumper and connected the shield with a 5V power adapter. but there still nothing happened.
then i've tried to connect the wires with M4 and M3, and correct the code, but the stepper stood still.

so. what am i doing wrong ?!

sorry, for my bad english... it's already very late...

here is the code i used:

#include <AFMotor.h>

AF_Stepper motor(48, 1);

void setup() {
  Serial.begin(9600);           // set up Serial library at 9600 bps
  Serial.println("Stepper test!");

  motor.setSpeed(10);  // 10 rpm   

  motor.step(100, FORWARD, SINGLE);

void loop() {
  motor.step(100, FORWARD, SINGLE);
  motor.step(100, BACKWARD, SINGLE);

  motor.step(100, FORWARD, DOUBLE);
  motor.step(100, BACKWARD, DOUBLE);

  motor.step(100, FORWARD, INTERLEAVE);
  motor.step(100, BACKWARD, INTERLEAVE);

  motor.step(100, FORWARD, MICROSTEP);
  motor.step(100, BACKWARD, MICROSTEP);


hey guys!

can't belive it. i've solved the problem.

my arduino was broken.

so, thx to everybody who read my post, and sorry to everybody that i've stolen your time....

be blessed!

Go Up

Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

via Egeo 16
Torino, 10131