Go Down

Topic: Boot loading 168A-PU (Read 560 times) previous topic - next topic

ars

Is ATMega 168A-PU compatible (physically) for boot loading arduino? If so, I always get an invalid device signature error when trying to bootload it from within the arduino IDE? How to successfully bootload it?

Nick Gammon

What board are you selecting?
Please post technical questions on the forum, not by personal message. Thanks!

More info:
http://www.gammon.com.au/electronics

Henrik67

Well, if you supply the correct device signature it should work...

ars

I am selecting the arduino NG or older board and is this IC physically compatible to handle arduino or am I just wasting my time?

Nick Gammon


Is ATMega 168A-PU compatible (physically) for boot loading arduino? If so, I always get an invalid device signature error when trying to bootload it from within the arduino IDE? How to successfully bootload it?


Quote
I am selecting the arduino NG or older board and is this IC physically compatible to handle arduino or am I just wasting my time?


Yes, of course, or the Atmega168 wouldn't be on the list. Perhaps if you describe in more detail. Your first post told us practically nothing. What programmer device are you using? What board are you using? Did you make it yourself? What is the wiring? Are you using a crystal? Photo please.
Please post technical questions on the forum, not by personal message. Thanks!

More info:
http://www.gammon.com.au/electronics

westfw

The ATmega168A has the same signature as the ATmega168, so it should work fine.
Turn on verbose mode to see what signature you are actually getting.

Go Up