Go Down

Topic: Adding libraries? (Read 1 time) previous topic - next topic

Baltasar

Hi, I just got my DUO and can't figure out how to install/add new librarys.

I'm trying to use a TFT library, but copying the folder the IDE is not detecting it and using the menu "Add Library" gives the error "Not a valid library", so anyone knows how this works now for 1.5 IDE?

Thanks.
Check all my projects based on Atmel/Arduino -> www.aqualed-light.com

Nantonos

There is a misfeature (which is apparently being removed, since community feedback showed it to be a bad idea) where if your library has any directories other than 'example' and 'utility' then it is flagged as bad and won't import.

(I forget now the exact spelling and capitalization of the two 'blessed' directory names. Hopefully that won't matter, soon)

Baltasar

#2
Oct 27, 2012, 06:17 pm Last Edit: Oct 27, 2012, 06:20 pm by Baltasar Reason: 1
Thanks, problem solved.

I get the corrent version from Github and compile it, now all is working ok with adding libraries by the menu or just put the folder there.

I think should be a good idea quickly change the download link on the DUO webpage to a current version at least without this bug so others don't get stuck with this problem.
Check all my projects based on Atmel/Arduino -> www.aqualed-light.com

Massimo Banzi

@Baltasar

We're going to provide a new download roughly on a weekly basis. We just released the software on monday so next week there will be a new version ready.
Cristian put together a buildbot, we're going to provide nightly builds in a few days. We have a few issues to iron out.

m

Go Up