Pages: [1]   Go Down
Author Topic: No text on I2C lcd serial blue 2004 from dx.com  (Read 2270 times)
0 Members and 1 Guest are viewing this topic.
0
Offline Offline
Newbie
*
Karma: 0
Posts: 11
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Regarding product sku.138616  , i cant get this display to work using an arduino uno.
the display i received has an other i2c driver on the back text says GY-LCD-V1 on the back.

The spec write it uses i2c address 0x27, but when i run an i2c scan it shows up at 0x20.

After changing to this address my backlight turns on and i see a blinking cursor but no text can be put on the display using de LiquidCruistal_i2c library.

wiring is correct , anybody got this display working ?

sample code used:
#include
#include

LiquidCrystal_I2C lcd(0x20,20,4); // set the LCD address to 0x27 for a 16 chars and 2 line display

void setup()
{
lcd.init(); // initialize the lcd
lcd.init();
// Print a message to the LCD.
lcd.backlight();
lcd.setCursor(3,0);
lcd.print("Hello, world!");
lcd.setCursor(2,1);
lcd.print("Ywrobot Arduino!");
lcd.setCursor(0,2);
lcd.print("Arduino LCM IIC 2004");
lcd.setCursor(2,3);
lcd.print("Power By Ec-yuan!");
}


void loop()
{
}
Logged

Western New York, USA
Offline Offline
Faraday Member
**
Karma: 39
Posts: 4383
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I believe that that board uses a serial backpack for its I2C interface and it is that board with which you are attempting to communicate.  

See if this thread helps, make sure you read it all the way through:  -->  http://arduino.cc/forum/index.php/topic,106655.0.html


Don

[EDIT]:  Here's another one -->  http://arduino.cc/forum/index.php/topic,128635.0.html
« Last Edit: October 28, 2012, 08:55:26 am by floresta » Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 11
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi , thanks for the info.

Managed to get it working with arduino 0.22 std i2c library.

Arduino 1.01 no luck ..

I also did try those links but no luck using arduino 1.01
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 11
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Sorry you where right

http://arduino.cc/forum/index.php/topic,106655.15.html

At the end , this was the solution many thanks !
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 2
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Sorry you where right

http://arduino.cc/forum/index.php/topic,106655.15.html

At the end , this was the solution many thanks !

I'm guessing you are referring to my post in that thread?  I just modified it to include a mention of "GY-LCD-V1" as thats exactly the same board I have..... and I knew I wouldnt be the only one spending hours getting the thing to work!  glad it helped you out.
Logged

Western New York, USA
Offline Offline
Faraday Member
**
Karma: 39
Posts: 4383
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
See if this thread helps, make sure you read it all the way through:  -->  http://arduino.cc/forum/index.php/topic,106655.0.html

Quote
I'm guessing you are referring to my post in that thread?
In my case, yes.  That is what I was referring to when I said "make sure you read it all the way through:".

Don
Logged

Pages: [1]   Go Up
Jump to: