Go Down

Topic: Sérial sans analog et vise versa ?[Résolu] (Read 421 times) previous topic - next topic

Fredo59

Oct 28, 2012, 09:36 pm Last Edit: Oct 28, 2012, 09:54 pm by Fredo59 Reason: 1
Bonjour,
je reviens vers vous a nouveau pour un petit soucis.

Lorsque je veux faire un son sur un petit hp : je me sers de la fonction analogWrite(2,127) par exemple et un "beep" sort de mon haut-parleur.

Mais lorsque j'utilise mon lcd sérial, plus moyen de sortir le moindre son, j'ai remarqué cela dès que je déclare la ligne slcd.begin a partir de ce moment plus un son ne sort sur la broche.
J'ai essayé plusieurs broches différentes mais rien a faire.

Si j'enlève la fonction slcd.begin (et que je n'emploie pas le lcd biensur) cela refonctionne.

Je voudrai savoir si c'est normal lorsqu'on utilise  les broches 0 et 1 en serial de ne plus pouvoir utiliser les autres broches en analogWrite ?


Merci
à Bientôt
L'expérience est une longue suite de bêtises...

Fredo59

Bon,
une fois n'est pas coutume !! j'ai trouvé tout seul.
Par ignorance de l'Arduino en fait, j'ai gratté un peu sur le net et je suis tombé sur un article qui parle des pin 3,5,7... et pas 2 !
J'ai donc modifié mon sketch vers la pin 3 et maintenant cela fonctionne....

Désolé du dérangement^^

A bientôt
L'expérience est une longue suite de bêtises...

Fredo59

Pour résumer et éviter d'induire des débutants (comme moi) en erreur, une précision s'impose.

Le son sur mon hp provient donc d'une broche configurée en sortie PWM et dans la documentation (que j'aurai du lire en premier lieu ^^) il est bien indiqué quelles broches sont utilisées  pour le PWM : 3,5,6,9,10,11

Voir le lien suivant :
http://www.mon-club-elec.fr/pmwiki_reference_arduino/pmwiki.php?n=Main.AnalogWrite

Je me suis donc mélangé les pieds avec les sorties sérial, PWM, analogue ect...


Voilà, maintenant c'est clair et complet  XD

A bientôt
L'expérience est une longue suite de bêtises...

Go Up