Pages: [1]   Go Down
Author Topic: Ayuda con modulo bluetooth de olimex BGB203  (Read 962 times)
0 Members and 1 Guest are viewing this topic.
Chile
Offline Offline
Newbie
*
Karma: 0
Posts: 42
Arduino Chile
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Estimados, hace unos dias adquiri un modulo bluetooth en Olimex

http://www.olimex.cl/product_info.php?cPath=46_59&products_id=861&product__name=BLUETOOTH_TRANSCIEVER_MODULE_WITH_BGB203

y pense que seria mas facil de lo esperado su implementacion.

1.- Alimenté con 3.3v de la placa arduino y GND, y pense que con solo aliemntarlo podria ser visible por algun dispositivo, lo que no fue asi(Primera frustracion)
2.-Conecte Rx del modulo a al Tx de la placa arduino (pasando por un divisor de tension para reducir el voltaje de transmision a 3.3v que lee la placa) y corri este sketch que encontre en internet para configurarlo (Segunda Frustración) ya que no respondio, no encendio ningun led no paso absolutamente nada de nada

Code:
void setup()
{
pinMode(LED, OUTPUT); // set direction of led pin
 
//default SparkFun BT module baud rate
Serial.begin(9600);
 
//Change module name
 Serial.print("AT+BTLNM=\"wirelessLilypad\"\r\n");
 delay(500);
 
 //Change UART settings (baud rate, data bits, stop bits, parity, stop bits, flow control)
 Serial.print("AT+BTURT=57600, 8, 0, 1, 0\r\n");
 delay(500);
 
 //Write settings on BGB203 flash memory
 Serial.print("AT+BTFLS\r\n");
 delay(500);
 
 //Start Bluetooth Server
 Serial.print("AT+BTSRV=1\r\n");
 delay(500);
 
}
 
void loop()
{

}

3.- cuando alimento el Modulo, enciende una luz Amarilla y no vuelve a prender mas y no se enciende ningun led. queda como si estubiera apagado.

Espero me puedan ayudar, que de verdad estoy muy decepcionado y no se que hacer con el modulo, ya que pense que seria mas facil de lo que estoy viendo. Muchas gracias de antemano!!
« Last Edit: May 15, 2012, 11:43:43 pm by Alonso Lazcano » Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 1
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi, I'm starting to play with this module and I have had the same problem.

In setup first of all, I configure serial port at 57600  "Serial.begin(57600);"
In this way I can view and connect via bluetooth to module.

Bye
« Last Edit: October 30, 2012, 01:59:50 am by cavelot » Logged

Pages: [1]   Go Up
Jump to: