Pages: 1 [2]   Go Down
Author Topic: MOFET selection to run 12v  (Read 1485 times)
0 Members and 1 Guest are viewing this topic.
Valencia, Spain
Offline Offline
Faraday Member
**
Karma: 142
Posts: 5301
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

What?  You shouldn't recommend this - a power MOSFET gate can be in range 1nF to 20nF, that's like a short-circuit load to an Arduino output pin on short timescales - they can only take 40mA abs max so a gate resistor of 150 ohms or so is recommended. 

OK, we can put it back in again now we know it's not the problem...

I agree, the circuit looks fine on paper. There must be a wiring error somewhere. Time to start measuring voltages at various points in the circuit. The usual culprit is Vgs when people put the transistor before the load in the circuit.


Logged

No, I don't answer questions sent in private messages (but I do accept thank-you notes...)

the land of sun+snow
Offline Offline
Faraday Member
**
Karma: 158
Posts: 2882
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Disconnect the ckt from the Arduino completely, and get it working first on it's own, then hook
to the Arduino. When the gate is pulled up [5 to 12V], the Leds should turn on "brightly", not
dimly.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 35
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

The project works! Thank you to EVERYONE on the forum who helped. In short: The MOSFET mentioned in the thread works but I understand not the best one out there...but it does work well.
Logged

Pottstown, PA
Offline Offline
Sr. Member
****
Karma: 5
Posts: 314
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

So how did you get it to work? - Scotty
Logged

Pages: 1 [2]   Go Up
Jump to: