Go Down

Topic: Problem mit FTDI FT232R USB UART (Read 1 time) previous topic - next topic

Chris72622

Hallo,

sobald ich einen Sketch übertragen möchte, meldet Arduino mir folgendes:

Der serielle Port '/dev/tty.usbserial-A8004ZpR' wird bereits verwendet. Probieren Sie, andere Programme zu beenden, die ihn benutzen könnten.

Binäre Sketchgröße: 15.214 Bytes (von einem Maximum von 30.720 Bytes)
processing.app.SerialException: Der serielle Port '/dev/tty.Bluetooth-PDA-Sync' wird bereits verwendet. Probieren Sie, andere Programme zu beenden, die ihn benutzen könnten.
   at processing.app.Serial.<init>(Serial.java:171)
   at processing.app.Serial.<init>(Serial.java:77)
   at processing.app.debug.Uploader.flushSerialBuffer(Uploader.java:77)
   at processing.app.debug.AvrdudeUploader.uploadViaBootloader(AvrdudeUploader.java:172)
   at processing.app.debug.AvrdudeUploader.uploadUsingPreferences(AvrdudeUploader.java:67)
   at processing.app.Sketch.upload(Sketch.java:1706)
   at processing.app.Sketch.exportApplet(Sketch.java:1662)
   at processing.app.Sketch.exportApplet(Sketch.java:1634)
   at processing.app.Editor$DefaultExportHandler.run(Editor.java:2346)
   at java.lang.Thread.run(Thread.java:680)
processing.app.debug.RunnerException: Der serielle Port '/dev/tty.Bluetooth-PDA-Sync' wird bereits verwendet. Probieren Sie, andere Programme zu beenden, die ihn benutzen könnten.
   at processing.app.debug.Uploader.flushSerialBuffer(Uploader.java:101)
   at processing.app.debug.AvrdudeUploader.uploadViaBootloader(AvrdudeUploader.java:172)
   at processing.app.debug.AvrdudeUploader.uploadUsingPreferences(AvrdudeUploader.java:67)
   at processing.app.Sketch.upload(Sketch.java:1706)
   at processing.app.Sketch.exportApplet(Sketch.java:1662)
   at processing.app.Sketch.exportApplet(Sketch.java:1634)
   at processing.app.Editor$DefaultExportHandler.run(Editor.java:2346)
   at java.lang.Thread.run(Thread.java:680)

Es sind aber keine anderen Programme geöffnet.

Das Ganze am Mac.

Gruß Chris
https://github.com/jeffThompson/DarkArduinoTheme

pylon

Kann es sein, dass die IDE zweimal läuft? Einmal vielleicht ohne Fenster geöffent zu haben? Ich würde zur Sicherheit einen Neustart empfehlen, dann die IDE starten und eine Übertragung versuchen. Wenn das geht, hatte sich die IDE wahrscheinlich irgendwie verarbschiedet, der Prozess blieb aber trotzdem hängen und deshalb waren die Schnittstellen gelockt.

Chris72622

#2
Oct 30, 2012, 07:11 pm Last Edit: Oct 30, 2012, 07:27 pm by Chris72622 Reason: 1
Hallo,

nein, leider hat das das das Problem nicht gelöst.

Habe eben festgestellt, dass das Anschließen eines Arduino Unos ebenfalls zu einer ähnlichen Fehlermeldung führt.

Auch in diesem Fall behauptet er, der serielle Anschluss wäre belegt.

Mittlerweile habe ich 10.7.5 erneut aufgespielt, aktuellste FTDI-Treiber geladen und Arduino 1.0.1 neu installiert.

Gruß Chris
https://github.com/jeffThompson/DarkArduinoTheme

Chris72622

Total verrückt und wenig Mac-like!

Dieser Link löste mein Problem:

http://arduino.cc/forum/index.php/topic,49173.0.html

Folgende Datei musste ich löschen (warum auch immer):

RXTXcomm.jar (zu finden unter HD/Library/Java/Extensions)

Gruß Chris
https://github.com/jeffThompson/DarkArduinoTheme

Go Up