Pages: [1]   Go Down
Author Topic: Capas de découplage ?  (Read 343 times)
0 Members and 1 Guest are viewing this topic.
perpignan, france
Offline Offline
Sr. Member
****
Karma: 0
Posts: 280
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Bonsoir

pour un projet où je dois utiliser un arduino proche d'un moteur diesel, j'ai de gros problèmes de perturbations EM lors de l'activation/arret du démarreur.

J'ai essayer de rajouter des capas de 100nF plastique un peu partout sur les alims et les lignes de données sensibles pour virer ces perturbations, mais sans grand succès.

Avez-vous des méthodes plus efficaces ou des valeurs précises de capa pour cet usage à me conseiller ?

Le schéma concerné est là : http://arduino.cc/forum/index.php?action=dlattach;topic=125887.0;attach=28335



La description du projet est ici : http://arduino.cc/forum/index.php/topic,125887.msg974621.html#msg974621
Logged

-tu savais que si tu passe le CD de windows à l'envers, tu entends une chanson satanique ?
-non, mais il y a pire : à l'endroit, ça l'instal

Offline Offline
Faraday Member
**
Karma: 19
Posts: 4170
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Bonsoir

pour un projet où je dois utiliser un arduino proche d'un moteur diesel, j'ai de gros problèmes de perturbations EM lors de l'activation/arret du démarreur.

J'ai essayer de rajouter des capas de 100nF plastique un peu partout sur les alims et les lignes de données sensibles pour virer ces perturbations, mais sans grand succès.

Avez-vous des méthodes plus efficaces ou des valeurs précises de capa pour cet usage à me conseiller ?

Le schéma concerné est là : http://arduino.cc/forum/index.php?action=dlattach;topic=125887.0;attach=28335



La description du projet est ici : http://arduino.cc/forum/index.php/topic,125887.msg974621.html#msg974621
si tu es sur que c'est le demarreur qui est le probleme (source des EM) et dans la mesure où je suppose que  tu ne peux pas intervenir dessus,
il ne reste qu'a essayer de faire transiter les lignes de l'arduino dans un tore ferrite et d'enfermer l'arduino dans un boitier blindé.
Logged

Ile-de-France (92 sud), France
Offline Offline
Edison Member
*
Karma: 23
Posts: 2054
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Je serais moins affirmatif sur le terme "perturbations EM"

Les perturbations électromagnétiques se manifestent par induction magnétique.
Contre cela les caps n'y feront rien mais un bon blindage oui.

Par contre les pics de courants dans les masses ou dans les alims, ce ne sont pas des perturbations EM et c'est plutôt par là qu'il faudrait cherché.

J'ai essayé de comprendre ton schéma et j'avoue que sans savoir la logique qui préside, il reste très mystérieux pour moi.

Par contre j'ai des doutes sur tes circuits d'alimentation et de masse.

Essaye d'avoir toutes les masses et les alims reliées en un seul point et câblées en étoile à partir de là.
Il faut éviter que les pics de courants qui se produisent à un endroit traverse la carte et influe sur d'autres alims.
Logged

Barbuduino: Arduino sur Breadboard & VinciDuino: Clone Leonardo // WR703: Mini-routeur hacké // LauchPad MSP430 et Stellaris // Panda II Arduino-like .NetMF sous VisualC#
RTFC: Read That F.....g Code / RTFD: Read That F.....g Doc / RTFDS: Read That F.....g DataSheet / RTFS: Read That F.....g Schematic / Wot da ya wanna D.I.Y. today ?

Ales
Offline Offline
Faraday Member
**
Karma: 29
Posts: 3174
Do or DIY
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Je serais également de l'avis de barbudor, les perturbations EM il en faudrait un paquet avant que ça te perturbe ... Mais comment se traduise exactement ces perturbations ? Reset ?
Logged


perpignan, france
Offline Offline
Sr. Member
****
Karma: 0
Posts: 280
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Bon alors il faut expliquer un peu à quoi sert tout ça : le but est d'avoir un fonctionnement automatique de groupe électrogène diesel. L'arduino doit donc sur demande externe (contact sec) faire démarrer le moteur, puis surveiller qu'il n'y a pas de défaut (calage, non démarrage, perte de pression d'huile) et réagir en conséquence.

Au départ, j'avais un reboot de l'arduino dès l'activation de démarreur Il s'est avéré que c'était dû à une grosse chute de tension de la batterie, ça s'est donc résolu par l'ajout d'une grosse capa (10 000µ) et d'une diode sur l'alim de la carte.
Ensuite, j'ai eu des détections farfelues au niveau des entrées, j'ai donc rajouté des capas de découplage un peu partout pour essayer de virer les pulses qui, je suppose, se baladent inopportunément, venant soit du démarreur, soit de l'alternateur de charge. Cela a semblé résoudre le problème, mais pas dans tous les cas.

Et c'est précisément le cas qui foire qui devrait être le mode le plus utilisé du système : la commande de démarrage externe.
Avec la commande locale, ça fonctionne (presque) à chaque fois.
Avec la commande externe, ça merde à chaque fois : le moteur démarre, puis l'arduino le coupe et signale "défaut calage" comme si le moteur avait calé de lui même. Comme le programme fonctionne quand je teste la carte sur le bureau avec des poussoirs pour simuler les capteurs, je suppose que le soucis vient du matériel et non du soft, mais je ne peux en être sur, pour une raison très claire :  quand la prise USB est raccordée sur la carte, d'une part, ça fonctionne (ce qui tendrait à suspecter un soucis sur l'alim, mais pourtant sa surveillance à l'oscillo ne laisse rien paraitre de suspect), et d'autre part : au moment ou sans l'USB, ça déconne, la liaison USB se réinitialise, et donc le temps de relancer la console sur le nouveau port, j'ai perdu le log qui me serait utile.

C'est ce décrochage de l'USB qui me fait dire "perturbations EM", mais sans doute suis-je à coté de la plaque.

J'ai du coup essayé d'utiliser le FTDI d'une autre nano grillée dont j'ai supprimé l'atmega comme convertisseur USB/TTL, que j'ai raccordé sur les pins TX, RX, et GND de la nano en place. Et bien rien, ça ne communique pas. http://arduino.cc/forum/index.php/topic,129661.0.html

En fait je crois que ce sujet fait doublon, vu que je me retrouve à expliquer deux fois la même chose.
Je n'aurais pas du le créer, il serait sans doute plus clair pour tout le monde de continuer la discussion sur le post d'origine : http://arduino.cc/forum/index.php/topic,125887.0.html
« Last Edit: October 30, 2012, 03:28:02 pm by bricofoy » Logged

-tu savais que si tu passe le CD de windows à l'envers, tu entends une chanson satanique ?
-non, mais il y a pire : à l'endroit, ça l'instal

Pages: [1]   Go Up
Jump to: