Go Down

Topic: [SOLVED] Arduino nano : is my USB chip dead ? (Read 406 times) previous topic - next topic

Emmanuel9999

May 03, 2015, 10:47 am Last Edit: May 14, 2015, 02:45 pm by Emmanuel9999 Reason: Picture too big
Hi there,

I may end up trashing my nano board, but I'd love to know if this is the result of a mistake I made or just a crappy chinese build. This is a question for the experts here and I'd be happy to learn from my mistake whatever it was...

I was playing around with my nano when some USB disconnections happened until it just stopped to be detected. If it is useful, I was powering a ultrasonic "sound ranger" with the chip using a TTL converter (5  to 3.3V, connected on both voltage on the chip).

Yes, it's a 340G chip. Yes, I have the correct driver (another nano is happy with it).

I did the loopback test, I burnt the bootloader (desperate move, eh...).

Still no USB detection, even on linux on another PC.

The only thing I can see on the circuit is a small "475" SMD cap that seems blackened. I have no idea if it was that way before.

I might have spent 5 or 6 hours trying to raise my nano from the deads with my friend Google.

Thanks for any help !


Peter_n

#1
May 03, 2015, 03:56 pm Last Edit: May 03, 2015, 03:57 pm by Peter_n
That capacitor is damaged. I think 475 is 4.7uF. The bar on the left is the positive side.
It is probably used for the voltage regulator (The AMS1117 above it).
But I don't know if it is for the 5V or the VIN.

Did you apply a high voltage of 12V or higher to VIN ?
Perhaps the heat from the AMS1117 damaged the capacitor.

Remove the capacitor. After that try running the board with usb power and nothing connected (only the usb cable).

Emmanuel9999

Thanks for taking the time to read my post !

I didn't apply a 12 V or higher voltage to VIN, it was just powered by the USB.

I removed the capacitor, the nano is still not detected. I tested the cap, it rates 4.7 uF.

So I guess I fried something else, maybe the CH340G USB chip ? I think the ATmega 328 is still ok because, before reflashing the bootloader, I could see the "TX" LED blinking the same way it was when executing the program as it was doing before the "accident".

The frustrating part is not knowing. If anyone has another idea, I'm still willing to try anything (except voodoo)! Maybe there is a way to bypass the USB chip ?






Peter_n

Sorry, I don't know either. The CH340G chip can be bypassed with a programmer.
A programmer is used to upload a sketch (the bootloader will be removed) or to write the bootloader.
A programmer can be USBasp version 2 (cheap) or an Arduino Uno (search for "ArduinoISP").

When only USB power was used, it is more lilkely that the 12MHz crystal was damaged instead of the CH340G chip. But since you bought a very cheap Arduino Nano clone, about anything can be broken  :smiley-confuse:
My advice is to buy a new new one  :smiley-money:  and forget about this one.

Emmanuel9999

Many thanks, you would not believe what I finally found : a bent pin in the mini USB socket (a data one).

Hopefully, this is not my day job...

Cheers

Peter_n


Isaac96

Do not PM me for help.Only links to topics.
CONNECT THE GROUNDS!

After Tuesday, even the calendar goes W T F

Emmanuel9999

With a needle, binocular magnifier and a lot of patience and maybe some luck. I figured that the problem began with some disconnections and ended up testing continuity on each pin (don't ask...).

The next step would have been to remove the USB socket and replace it, well, I'm glad I didn't had to because I don't have much soldering skills.

Thanks again to Peter for his support

philb_au

Well, my USB is dead from another reason.
Last night after uploading code nothing happened.
I re-plugged into USB and still nothing.

Tonight I put it back into a CH adapter board and external PS works fine.

Something has fried the (I assume) USB power diode, and as I haven't changed anything
it's a bit off a mystery.

Hopefully the attached pic will show the 'bubble of misfortune'.

Anyone else with this problem?

philb_au

Hi All,

A slightly different problem with another 'CH'eap Nano.

Looks like it failed when re-plugging into USB.

Not many other components (RTC clock) but after it working for a a long time
it failed.

Hopefully an attached pic will show the component which I assume WAS a diode.

Anyone else with this issue?


Peter_n

Perhaps a resistor of 0 ohm as fuse ? or a diode ?
When that happened, what was connected to the pins of the Nano ? Could there be a current path to ground.

Go Up