Go Down

Topic: avrdude: stk500_getsync(): not in sync: resp=0x00 (Read 255 times) previous topic - next topic

Anaroyondo

Hi everyone !

I'm quite new to the arduino world so I don't understand everything is going on.
I have a Arduino Duemilanove and 2 Atmega 328P-PU.
Both Atmega are identical, except for a number upper-right (one is 1347, other is 1416).

From my google searches i can say : I checked my COM port (i use COM3), the drivers are OK, my #13 LED is blinking when I plug my Arduino to my computer by USB (so the bootloader is OK, isn't it ?) and no PIN is used or even plugged.

I get this error just from the 1416 one, while the 1347 is totally fine so I really don't understand where the problem could be.
The error is the same if I upload some code (custom or blink example), or if I burn the bootloader (sprry, my IDE is not in english, I talk about the last item of the "tool" menu, I'm quite sure it is to burn the bootloader).

Thanks for any help !

Anaroyondo

I just bought a third ATMega 328P, numbered 1344, and I have the same problem (so I only have one out of 3 that work).
I try burning the bootloader by doing this : http://arduino.cc/en/Tutorial/ArduinoToBreadboard, but still got this annoying error....

Should it be possible that my bootloader is for Arduino Uno and not for Duemilanove ?
Any idea for my problem ?

Thanks

Anaroyondo

Ok I keep responding to myself but this problem is kinda solved.
Actually it was absolutely not obvious that the board had to have an ATmega chip loaded to burn the bootloader on another :s
So now I have another error, but I'm gonna start another topic on it, so the title would be better.

Icecube101

Hi,

Just wanted to reply, because I spent quite a bit of time to solve this problem, and I want to share the solution that finally worked for me (obviously double check the selected board and com port first, under Tools -> Board and Tools -> Serial port). One of the symptoms in my case, was that the reset button did not appear to be doing anything.

In the end, I found the solution that worked on this page: link.

Quote
Remove the USB connection, close the IDE, open the IDE, open BareMinimum, hold the reset button, plugin the USB connection, click the upload button 1/2 a second after removing your finger from the reset button.


I did it slightly differently; I was holding the reset button until the IDE was almost done compiling.

Go Up