Pages: [1]   Go Down
Author Topic: Windows 8 and Arduino 1.0.1  (Read 1884 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Jr. Member
**
Karma: 0
Posts: 91
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi,
Ive been using Ardiuno on my computer for some time now. i have recently upgraded to Windows 8.
I initially had the problem with installing the driver for the Uno, but found that fix fairly easily.

With with either 1.0 or 1.0.1 i cannot get the software to see the Arduino on the serial port. I have reassigned a different port number, reinstalled the drivers, rebooted.
It sometimes sees it when i assign port 8, but said that it is in use when i try to upload a sketch. Mostly it just doesnt see that there is a Serial port there at all.

It is the exact same hardware configuration that was working with windows 7.
Logged

Offline Offline
Jr. Member
**
Karma: 0
Posts: 91
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

No one has any ideas at all? It would be good to get it working again. Working off my laptop isnt as much fun...
Logged

Tucson, AZ
Offline Offline
Sr. Member
****
Karma: 4
Posts: 272
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

What happens when you plug it in?  Do you get the device insertion sound?  Does Windows say it's installing a driver?  When it does show up under COM 8, can you right-click and tell it to update the driver, and then navigate to the drivers folder to install the driver?  What happens if you do that?  Have you tries to right-click in the .inf file in the driver folder and choose install?  If so, what happens when you do that?  Specific error messages are important here, so please make note of them.
Logged

Offline Offline
Jr. Member
**
Karma: 0
Posts: 91
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Ok, I haven even looked at it since i posted this. Just been using it on my laptop. Tried again and it works. musta been a windows update cos nothing else is different. weird.
Logged

Offline Offline
Jr. Member
**
Karma: 0
Posts: 91
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Spoke too soon. it worked for one upload. now its doing this again. (see screenshot)


* no serial.png (60.44 KB, 1075x807 - viewed 39 times.)
Logged

Grand Blanc, MI, USA
Offline Offline
Faraday Member
**
Karma: 71
Posts: 3536
CODE is a mass noun and should not be used in the plural or with an indefinite article.
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Just a SWAG, I have an old XP machine that does something similar. Works for a while, then the port just disappears, have to reboot to get it back. OTOH, a newer machine I have with Win 8 seems fine. I've been too lazy to look into it, but I might check the PC manufacturer's website and make sure all the latest drivers are installed.
Logged

MCP79411/12 RTC ... "One Million Ohms" ATtiny kit ... available at http://www.tindie.com/stores/JChristensen/

Atlanta, USA
Offline Offline
Edison Member
*
Karma: 34
Posts: 1476
AKA: Ray Burne
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Older machines that have been upgraded that are having Win8 issues where hardware seems to work and then doesn't ... then does, is likely a hardware failure at initializing (enumerating a port) in the plug & play environment.  If the PC is a desktop, try moving to another port on a different internal HUB.  If you only have one internal HUB, buy a cheap external hub (or borrow one first) and give that a try.

I have two notebooks, both designed for Win7 and one works perfectly on Win8 (64-bit) and one is iffy (win-32).  From what I can determine, the win-32 bit drivers are significantly older and newer drivers cannot be obtained.


- Ray
Logged

Offline Offline
Jr. Member
**
Karma: 0
Posts: 91
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Thanks Ray,
It is a not-to-old core2quad PC. So desktop with plenty of USB ports and controllers. i have tried numerous.
It worked for that one upload and hasnt worked since. ive just been using my laptop. it would be good to get a solution to this (rather work on bigger screens), but as it works on the laptop its not imperative.
Logged

Pages: [1]   Go Up
Jump to: