Go Down

Topic: arduino servo problem( es 08a model) (Read 1 time) previous topic - next topic


Hello people

I have a problem with to run the servo(es08a model)

Code: [Select]
#include <Servo.h>

Servo myservo;

int pos =0;

void setup()

void loop()
  for(pos =0; pos <180 ; pos+=1)
  for(pos = 180; pos>=1; pos-=1)

this is my code and

I checked the power supply for 5v is working
and black to ground red to 5v and yellow to right pin(5)

I have been tried many different code but still give me the same result
( It only move for 0.00001 second when i disconnect the red pin and reconnect it)




that was my post their information is not working


And you think that by posting in a different thread is going to help?

The members that are helping you know what they are talking about.  But, YOU need to help yourself first.  If you want someone to program the Arduino for you, then pay someone to do it.

The mods will merge your posts together anyway, once they see this.


You still do not seem to be using separate power for your servo.

Its not about the volts, its about the amps. Your servo wants more amps than your Arduino is able to supply.

Again, check the two links below, use seperate power and then let us know if you have a problem

Duane B
Read this
then watch this


Go Up

Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

via Egeo 16
Torino, 10131